summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2019-01-25 12:48:11 +0200
committerMikko Gronoff <mikko.gronoff@qt.io>2019-01-28 08:30:58 +0000
commitbe15ea860dda1317e786393ab396775d7e3bf83b (patch)
tree3be23f07c6d9a68677224a01a4a7eec149d45c80
parenta0e0bd8facb4c49675c3f323a2486035b9ae4187 (diff)
downloadmeta-boot2qt-be15ea860dda1317e786393ab396775d7e3bf83b.tar.gz
meta-qt5: update layer
Update to latest content in Qt 5.12.1 branch (RC2), remove upstreamed patch. Change-Id: Iea9e6a9358e377c71fa7ad368ba4bffd78c6f497 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
-rw-r--r--meta-fsl-extras/recipes/qt5/qtbase/0001-egl_viv-cast-EGLNative-types-from-vivante-functions.patch57
-rw-r--r--meta-fsl-extras/recipes/qt5/qtbase_git.bbappend33
-rw-r--r--scripts/manifest.xml2
3 files changed, 1 insertions, 91 deletions
diff --git a/meta-fsl-extras/recipes/qt5/qtbase/0001-egl_viv-cast-EGLNative-types-from-vivante-functions.patch b/meta-fsl-extras/recipes/qt5/qtbase/0001-egl_viv-cast-EGLNative-types-from-vivante-functions.patch
deleted file mode 100644
index dc56cfc..0000000
--- a/meta-fsl-extras/recipes/qt5/qtbase/0001-egl_viv-cast-EGLNative-types-from-vivante-functions.patch
+++ /dev/null
@@ -1,57 +0,0 @@
1From 40e76307c1ee1ebe4e0142d623071d0f768f2450 Mon Sep 17 00:00:00 2001
2From: Samuli Piippo <samuli.piippo@qt.io>
3Date: Wed, 9 Jan 2019 13:01:01 +0000
4Subject: [PATCH] egl_viv: cast EGLNative types from vivante functions
5
6All vivante functions return void* even when the actual native type
7(EGLNativeDisplayType, EGLNativeWindowType, etc.) might be typedef'ed
8as something else, as they do when the CFLAGS from egl.pc are now used.
9---
10 .../deviceintegration/eglfs_viv/qeglfsvivintegration.cpp | 4 ++--
11 .../deviceintegration/eglfs_viv_wl/qeglfsvivwlintegration.cpp | 4 ++--
12 2 files changed, 4 insertions(+), 4 deletions(-)
13
14diff --git a/src/plugins/platforms/eglfs/deviceintegration/eglfs_viv/qeglfsvivintegration.cpp b/src/plugins/platforms/eglfs/deviceintegration/eglfs_viv/qeglfsvivintegration.cpp
15index 763a4a462b..2fc076ad0c 100644
16--- a/src/plugins/platforms/eglfs/deviceintegration/eglfs_viv/qeglfsvivintegration.cpp
17+++ b/src/plugins/platforms/eglfs/deviceintegration/eglfs_viv/qeglfsvivintegration.cpp
18@@ -65,7 +65,7 @@ void QEglFSVivIntegration::platformInit()
19 VivanteInit();
20 mNativeDisplay = fbGetDisplay();
21 #else
22- mNativeDisplay = fbGetDisplayByIndex(framebufferIndex());
23+ mNativeDisplay = static_cast<EGLNativeDisplayType>(fbGetDisplayByIndex(framebufferIndex()));
24 #endif
25
26 fbGetDisplayGeometry(mNativeDisplay, &width, &height);
27@@ -88,7 +88,7 @@ EGLNativeWindowType QEglFSVivIntegration::createNativeWindow(QPlatformWindow *wi
28 Q_UNUSED(window)
29 Q_UNUSED(format)
30
31- EGLNativeWindowType eglWindow = fbCreateWindow(mNativeDisplay, 0, 0, size.width(), size.height());
32+ EGLNativeWindowType eglWindow = static_cast<EGLNativeWindowType>(fbCreateWindow(mNativeDisplay, 0, 0, size.width(), size.height()));
33 return eglWindow;
34 }
35
36diff --git a/src/plugins/platforms/eglfs/deviceintegration/eglfs_viv_wl/qeglfsvivwlintegration.cpp b/src/plugins/platforms/eglfs/deviceintegration/eglfs_viv_wl/qeglfsvivwlintegration.cpp
37index 61e2f17766..3bdae239cd 100644
38--- a/src/plugins/platforms/eglfs/deviceintegration/eglfs_viv_wl/qeglfsvivwlintegration.cpp
39+++ b/src/plugins/platforms/eglfs/deviceintegration/eglfs_viv_wl/qeglfsvivwlintegration.cpp
40@@ -60,7 +60,7 @@ void QEglFSVivWaylandIntegration::platformInit()
41 }
42
43 mWaylandDisplay = wl_display_create();
44- mNativeDisplay = fbGetDisplay(mWaylandDisplay);
45+ mNativeDisplay = static_cast<EGLNativeDisplayType>(fbGetDisplay(mWaylandDisplay));
46 fbGetDisplayGeometry(mNativeDisplay, &width, &height);
47 mScreenSize.setHeight(height);
48 mScreenSize.setWidth(width);
49@@ -81,7 +81,7 @@ EGLNativeWindowType QEglFSVivWaylandIntegration::createNativeWindow(QPlatformWin
50 Q_UNUSED(window)
51 Q_UNUSED(format)
52
53- EGLNativeWindowType eglWindow = fbCreateWindow(mNativeDisplay, 0, 0, size.width(), size.height());
54+ EGLNativeWindowType eglWindow = static_cast<EGLNativeWindowType>(fbCreateWindow(mNativeDisplay, 0, 0, size.width(), size.height()));
55 return eglWindow;
56 }
57
diff --git a/meta-fsl-extras/recipes/qt5/qtbase_git.bbappend b/meta-fsl-extras/recipes/qt5/qtbase_git.bbappend
deleted file mode 100644
index 373e614..0000000
--- a/meta-fsl-extras/recipes/qt5/qtbase_git.bbappend
+++ /dev/null
@@ -1,33 +0,0 @@
1############################################################################
2##
3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
31SRC_URI += " \
32 file://0001-egl_viv-cast-EGLNative-types-from-vivante-functions.patch \
33 "
diff --git a/scripts/manifest.xml b/scripts/manifest.xml
index 65d4a53..979e4ca 100644
--- a/scripts/manifest.xml
+++ b/scripts/manifest.xml
@@ -26,7 +26,7 @@
26 path="sources/meta-openembedded"/> 26 path="sources/meta-openembedded"/>
27 <project name="meta-qt5" 27 <project name="meta-qt5"
28 remote="qtyocto" 28 remote="qtyocto"
29 revision="70e4a1c9c9a7e264e710f4e6c2abbc0fcd0727cd" 29 revision="0f27849166952e5ca377084a0746182169eaf324"
30 path="sources/meta-qt5"/> 30 path="sources/meta-qt5"/>
31 <project name="meta-mingw" 31 <project name="meta-mingw"
32 remote="qtyocto" 32 remote="qtyocto"