summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2019-01-04 14:51:39 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2019-01-07 15:08:21 +0000
commitbce54374aa6783508fb8bed3a3c547b061384f1a (patch)
tree9e851a6da2f6e15ed680d5cb64b64de3bb907a9b
parent0f191b2fb735243df629b93e2bb1d7cc7e8c63fc (diff)
downloadmeta-boot2qt-bce54374aa6783508fb8bed3a3c547b061384f1a.tar.gz
draak: fix linux-libc-header do_install step
Override install step and remove header that does not exist in the draak's version of the linux-libc-headers. Fix "oe_multilib_header: Unable to find header asm/bpf_perf_event.h." Change-Id: I3a4f08a8e7ad9683b39c3cb5db014446e4c069a1 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--meta-renesas-extras/recipes/linux-libc-headers/linux-libc-headers_%.bbappend34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-renesas-extras/recipes/linux-libc-headers/linux-libc-headers_%.bbappend b/meta-renesas-extras/recipes/linux-libc-headers/linux-libc-headers_%.bbappend
new file mode 100644
index 0000000..e1022d8
--- /dev/null
+++ b/meta-renesas-extras/recipes/linux-libc-headers/linux-libc-headers_%.bbappend
@@ -0,0 +1,34 @@
1############################################################################
2##
3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30# override to remove asm/bpf_perf_event.h
31do_install_armmultilib_draak () {
32 oe_multilib_header asm/auxvec.h asm/bitsperlong.h asm/byteorder.h asm/fcntl.h asm/hwcap.h asm/ioctls.h asm/kvm.h asm/kvm_para.h asm/mman.h asm/param.h asm/perf_regs.h
33 oe_multilib_header asm/posix_types.h asm/ptrace.h asm/setup.h asm/sigcontext.h asm/siginfo.h asm/signal.h asm/stat.h asm/statfs.h asm/swab.h asm/types.h asm/unistd.h
34}