summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-12-10 17:01:58 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2018-12-11 08:50:01 +0000
commit876c3484ba590fa1075fd58e89c0472b403c42d8 (patch)
tree6d95cf33dccf3d9293faa399d57bb382d5cdd8d7
parent45e9c47aa43982c20485241fcb50bdec63b351af (diff)
downloadmeta-boot2qt-876c3484ba590fa1075fd58e89c0472b403c42d8.tar.gz
automotive: update module revisions
Change-Id: Ife07f39c2809ac984e89aeb38919129d7fa6447f Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--meta-boot2qt/recipes-qt/automotive/neptune3-ui/neptune.service2
-rw-r--r--meta-boot2qt/recipes-qt/automotive/neptune3-ui_git.bb8
-rw-r--r--meta-boot2qt/recipes-qt/automotive/qmllive_git.bb2
-rw-r--r--meta-boot2qt/recipes-qt/automotive/qtapplicationmanager_git.bb2
-rw-r--r--meta-boot2qt/recipes-qt/automotive/qtivi_git.bb2
5 files changed, 8 insertions, 8 deletions
diff --git a/meta-boot2qt/recipes-qt/automotive/neptune3-ui/neptune.service b/meta-boot2qt/recipes-qt/automotive/neptune3-ui/neptune.service
index 876509f..8139139 100644
--- a/meta-boot2qt/recipes-qt/automotive/neptune3-ui/neptune.service
+++ b/meta-boot2qt/recipes-qt/automotive/neptune3-ui/neptune.service
@@ -3,7 +3,7 @@ Description=Neptune
3After=dbus.service dbus-session.service systemd-user-sessions.service 3After=dbus.service dbus-session.service systemd-user-sessions.service
4 4
5[Service] 5[Service]
6ExecStart=/usr/bin/appcontroller /opt/neptune3/neptune3-ui -r --dbus session -c am-config.yaml 6ExecStart=/usr/bin/appcontroller /opt/neptune3/neptune3-ui -r --dbus session -c am-config-neptune.yaml
7Restart=on-failure 7Restart=on-failure
8WorkingDirectory=/opt/neptune3 8WorkingDirectory=/opt/neptune3
9Environment=AM_STARTUP_TIMER=1 9Environment=AM_STARTUP_TIMER=1
diff --git a/meta-boot2qt/recipes-qt/automotive/neptune3-ui_git.bb b/meta-boot2qt/recipes-qt/automotive/neptune3-ui_git.bb
index 3ad29b1..da0f658 100644
--- a/meta-boot2qt/recipes-qt/automotive/neptune3-ui_git.bb
+++ b/meta-boot2qt/recipes-qt/automotive/neptune3-ui_git.bb
@@ -32,7 +32,7 @@ DESCRIPTION = "Neptune 3 IVI UI"
32LICENSE = "Apache-2.0 & ( GPL-3.0 | The-Qt-Company-Commercial )" 32LICENSE = "Apache-2.0 & ( GPL-3.0 | The-Qt-Company-Commercial )"
33LIC_FILES_CHKSUM = "\ 33LIC_FILES_CHKSUM = "\
34 file://LICENSE.GPL3;md5=0d02f21f8e2533ecc519e2ed96bc94a2 \ 34 file://LICENSE.GPL3;md5=0d02f21f8e2533ecc519e2ed96bc94a2 \
35 file://imports/assets/fonts/LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57 \ 35 file://imports_shared/assets/fonts/LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57 \
36" 36"
37 37
38inherit qt5-module systemd 38inherit qt5-module systemd
@@ -45,7 +45,7 @@ SRC_URI += " \
45 file://neptune.service \ 45 file://neptune.service \
46 " 46 "
47 47
48SRCREV = "d8332c73ccda36e1da2661317d7ed3c787b17c68" 48SRCREV = "c80d9aba17b1b50618ae6311d48f35ec726a4007"
49 49
50QMAKE_PROFILES = "${S}/neptune3-ui.pro" 50QMAKE_PROFILES = "${S}/neptune3-ui.pro"
51 51
@@ -74,8 +74,8 @@ do_install_append() {
74 74
75 # Move the fonts to the system-wide font location 75 # Move the fonts to the system-wide font location
76 install -m 0755 -d ${D}${datadir}/fonts/ttf/ 76 install -m 0755 -d ${D}${datadir}/fonts/ttf/
77 mv ${D}/opt/neptune3/imports/assets/fonts/*.ttf ${D}${datadir}/fonts/ttf/ 77 mv ${D}/opt/neptune3/imports_shared/assets/fonts/*.ttf ${D}${datadir}/fonts/ttf/
78 rm -rf ${D}/opt/neptune3/imports/assets/fonts/ 78 rm -rf ${D}/opt/neptune3/imports_shared/assets/fonts/
79 79
80 # Don't package tests 80 # Don't package tests
81 rm -rf ${D}/usr/share/tests 81 rm -rf ${D}/usr/share/tests
diff --git a/meta-boot2qt/recipes-qt/automotive/qmllive_git.bb b/meta-boot2qt/recipes-qt/automotive/qmllive_git.bb
index d87dd13..52cfcff 100644
--- a/meta-boot2qt/recipes-qt/automotive/qmllive_git.bb
+++ b/meta-boot2qt/recipes-qt/automotive/qmllive_git.bb
@@ -37,7 +37,7 @@ require recipes-qt/qt5/qt5-git.inc
37 37
38QT_GIT_PROJECT = "qt-apps" 38QT_GIT_PROJECT = "qt-apps"
39 39
40SRCREV = "e400161c6ec932c180e8b9fe5e5d00a593ee254a" 40SRCREV = "329a996f6a52494ef677107593a0146c71a2880a"
41 41
42DEPENDS = "qtbase qtdeclarative" 42DEPENDS = "qtbase qtdeclarative"
43 43
diff --git a/meta-boot2qt/recipes-qt/automotive/qtapplicationmanager_git.bb b/meta-boot2qt/recipes-qt/automotive/qtapplicationmanager_git.bb
index 89fcaa2..c267e3f 100644
--- a/meta-boot2qt/recipes-qt/automotive/qtapplicationmanager_git.bb
+++ b/meta-boot2qt/recipes-qt/automotive/qtapplicationmanager_git.bb
@@ -35,7 +35,7 @@ inherit qt5-module
35require recipes-qt/qt5/qt5-git.inc 35require recipes-qt/qt5/qt5-git.inc
36 36
37QT_MODULE_BRANCH = "dev" 37QT_MODULE_BRANCH = "dev"
38SRCREV = "941d493f47d1e15430ed062ea0aa4b1f7c087a04" 38SRCREV = "adb57812ee1cf89f3311f8a27ef97abf5d424bde"
39 39
40DEPENDS = "qtbase qtdeclarative libyaml libarchive \ 40DEPENDS = "qtbase qtdeclarative libyaml libarchive \
41 ${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland qtwayland-native", "", d)}" 41 ${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland qtwayland-native", "", d)}"
diff --git a/meta-boot2qt/recipes-qt/automotive/qtivi_git.bb b/meta-boot2qt/recipes-qt/automotive/qtivi_git.bb
index 01a7d4b..4b122c2 100644
--- a/meta-boot2qt/recipes-qt/automotive/qtivi_git.bb
+++ b/meta-boot2qt/recipes-qt/automotive/qtivi_git.bb
@@ -51,7 +51,7 @@ SRC_URI += " \
51 file://0001-Use-QT_HOST_BINS-get-for-getting-correct-path.patch \ 51 file://0001-Use-QT_HOST_BINS-get-for-getting-correct-path.patch \
52" 52"
53 53
54SRCREV_qtivi = "142d7174863c2acf2792ba723c8dd273f8d07b22" 54SRCREV_qtivi = "15a6672b304fe91a928911e810f5e83f233c790e"
55SRCREV_qface = "0a3ae7686e1100be452b8c435bdcd84ec242340e" 55SRCREV_qface = "0a3ae7686e1100be452b8c435bdcd84ec242340e"
56SRCREV = "${SRCREV_qtivi}" 56SRCREV = "${SRCREV_qtivi}"
57SRCREV_FORMAT = "qtivi_qface" 57SRCREV_FORMAT = "qtivi_qface"