summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2019-01-11 09:27:20 +0200
committerMikko Gronoff <mikko.gronoff@qt.io>2019-01-11 09:28:01 +0200
commit75e93a6ecb121d9aa0ee4aa986b3eef0dd20ea22 (patch)
tree9c50c69852153a629d6507925c198ab09502ee4d
parentff68de7e1d41b2cd81b0ffd16759d2c738554705 (diff)
parentb97117dfe83a5b73e8d27c6818902e0d1cfca7ba (diff)
downloadmeta-boot2qt-75e93a6ecb121d9aa0ee4aa986b3eef0dd20ea22.tar.gz
Merge remote-tracking branch 'origin/QtAS-5.12.0' into sumo
* origin/QtAS-5.12.0: b97117d automotive: update revisions 4281e5b automotive: update revisions b344daf automotive: update neptune 3 revision a143fbc Use ABI flavor with QtCreator 9ee5a7f QBSP: add correct cmake generator for windows toolchain 8fcf3a1 meta-qt5: update revision 0385367 Merge commit 'origin/sumo' into QtAS-5.12.0 9a57170 automotive: update revisions Conflicts: scripts/manifest.xml Change-Id: I3064a526fd7861ea1aa0ec9b42c016c74dbc23eb
-rw-r--r--meta-boot2qt/classes/populate_b2qt_qt5_sdk.bbclass2
-rw-r--r--meta-boot2qt/classes/qbsp.bbclass3
-rwxr-xr-xmeta-boot2qt/files/configure-qtcreator.sh6
-rw-r--r--meta-boot2qt/files/qbsp/toolchain_installscript.qs9
-rw-r--r--meta-boot2qt/recipes-qt/automotive/neptune3-ui_git.bb4
-rw-r--r--meta-boot2qt/recipes-qt/automotive/qmllive_git.bb4
-rw-r--r--meta-boot2qt/recipes-qt/automotive/qtapplicationmanager_git.bb4
-rw-r--r--meta-boot2qt/recipes-qt/automotive/qtivi_git.bb2
8 files changed, 23 insertions, 11 deletions
diff --git a/meta-boot2qt/classes/populate_b2qt_qt5_sdk.bbclass b/meta-boot2qt/classes/populate_b2qt_qt5_sdk.bbclass
index f35ebfe..6278d11 100644
--- a/meta-boot2qt/classes/populate_b2qt_qt5_sdk.bbclass
+++ b/meta-boot2qt/classes/populate_b2qt_qt5_sdk.bbclass
@@ -91,7 +91,7 @@ create_qtcreator_configure_script () {
91 # add qtcreator configuration script 91 # add qtcreator configuration script
92 install -m 0755 ${B2QTBASE}/files/configure-qtcreator.sh ${SDK_OUTPUT}/${SDKPATH} 92 install -m 0755 ${B2QTBASE}/files/configure-qtcreator.sh ${SDK_OUTPUT}/${SDKPATH}
93 sed -i -e '/^CONFIG=/c\CONFIG="${SDKPATH}/environment-setup-${REAL_MULTIMACH_TARGET_SYS}"' ${SDK_OUTPUT}/${SDKPATH}/configure-qtcreator.sh 93 sed -i -e '/^CONFIG=/c\CONFIG="${SDKPATH}/environment-setup-${REAL_MULTIMACH_TARGET_SYS}"' ${SDK_OUTPUT}/${SDKPATH}/configure-qtcreator.sh
94 sed -i -e '/^ABI=/c\ABI="${ABI}-linux-generic-elf-${SITEINFO_BITS}bit"' ${SDK_OUTPUT}/${SDKPATH}/configure-qtcreator.sh 94 sed -i -e '/^ABI=/c\ABI="${ABI}-linux-poky-elf-${SITEINFO_BITS}bit"' ${SDK_OUTPUT}/${SDKPATH}/configure-qtcreator.sh
95} 95}
96 96
97create_qtcreator_configure_script_sdkmingw32 () { 97create_qtcreator_configure_script_sdkmingw32 () {
diff --git a/meta-boot2qt/classes/qbsp.bbclass b/meta-boot2qt/classes/qbsp.bbclass
index fbfd266..d61e12b 100644
--- a/meta-boot2qt/classes/qbsp.bbclass
+++ b/meta-boot2qt/classes/qbsp.bbclass
@@ -27,7 +27,7 @@
27## 27##
28############################################################################ 28############################################################################
29 29
30inherit meta nopackages abi-arch 30inherit meta nopackages abi-arch siteinfo
31 31
32FILESEXTRAPATHS_prepend := "${B2QTBASE}/files/qbsp:" 32FILESEXTRAPATHS_prepend := "${B2QTBASE}/files/qbsp:"
33 33
@@ -87,6 +87,7 @@ patch_installer_files() {
87 -e "s#@SYSROOT@#${REAL_MULTIMACH_TARGET_SYS}#" \ 87 -e "s#@SYSROOT@#${REAL_MULTIMACH_TARGET_SYS}#" \
88 -e "s#@TARGET_SYS@#${TARGET_SYS}#" \ 88 -e "s#@TARGET_SYS@#${TARGET_SYS}#" \
89 -e "s#@ABI@#${ABI}#" \ 89 -e "s#@ABI@#${ABI}#" \
90 -e "s#@BITS@#${SITEINFO_BITS}#" \
90 -e "s#@INSTALLPATH@#${QBSP_INSTALL_PATH}#" \ 91 -e "s#@INSTALLPATH@#${QBSP_INSTALL_PATH}#" \
91 -e "s#@SDKPATH@#${SDKPATH}#" \ 92 -e "s#@SDKPATH@#${SDKPATH}#" \
92 -e "s#@SDKFILE@#${SDK_NAME}#" \ 93 -e "s#@SDKFILE@#${SDK_NAME}#" \
diff --git a/meta-boot2qt/files/configure-qtcreator.sh b/meta-boot2qt/files/configure-qtcreator.sh
index a7ea288..6899fc3 100755
--- a/meta-boot2qt/files/configure-qtcreator.sh
+++ b/meta-boot2qt/files/configure-qtcreator.sh
@@ -30,7 +30,7 @@
30 30
31set -e 31set -e
32 32
33ABI="arm-linux-generic-elf-32bit" 33ABI="arm-linux-poky-elf-32bit"
34CONFIG="" 34CONFIG=""
35 35
36printUsage () 36printUsage ()
@@ -107,6 +107,10 @@ if [ -n "${REMOVEONLY}" ]; then
107 exit 0 107 exit 0
108fi 108fi
109 109
110${SDKTOOL} addAbiFlavor \
111 --flavor poky \
112 --oses linux || true
113
110${SDKTOOL} addTC \ 114${SDKTOOL} addTC \
111 --id "ProjectExplorer.ToolChain.Gcc:${BASEID}.gcc" \ 115 --id "ProjectExplorer.ToolChain.Gcc:${BASEID}.gcc" \
112 --name "GCC (${NAME})" \ 116 --name "GCC (${NAME})" \
diff --git a/meta-boot2qt/files/qbsp/toolchain_installscript.qs b/meta-boot2qt/files/qbsp/toolchain_installscript.qs
index 4d25bf7..32c14e0 100644
--- a/meta-boot2qt/files/qbsp/toolchain_installscript.qs
+++ b/meta-boot2qt/files/qbsp/toolchain_installscript.qs
@@ -40,7 +40,7 @@ Component.prototype.createOperations = function()
40 var sysroot = "@SYSROOT@" 40 var sysroot = "@SYSROOT@"
41 var target_sys = "@TARGET_SYS@" 41 var target_sys = "@TARGET_SYS@"
42 var target = "@TARGET@" 42 var target = "@TARGET@"
43 var abi = "@ABI@" 43 var abi = "@ABI@-linux-poky-elf-@BITS@bit"
44 var installPath = "@INSTALLPATH@/toolchain" 44 var installPath = "@INSTALLPATH@/toolchain"
45 var sdkPath = "@SDKPATH@" 45 var sdkPath = "@SDKPATH@"
46 var sdkFile = "@SDKFILE@" 46 var sdkFile = "@SDKFILE@"
@@ -73,8 +73,14 @@ Component.prototype.createOperations = function()
73 executableExt = ".exe"; 73 executableExt = ".exe";
74 hostSysroot = "i686-pokysdk-mingw32"; 74 hostSysroot = "i686-pokysdk-mingw32";
75 toolchainId = "ProjectExplorer.ToolChain.Mingw:" + component.name; 75 toolchainId = "ProjectExplorer.ToolChain.Mingw:" + component.name;
76 cmakeGenerator = "MinGW Makefiles";
76 } 77 }
77 78
79 component.addOperation("Execute", "{0,2}",
80 ["@SDKToolBinary@", "addAbiFlavor",
81 "--flavor", "poky",
82 "--oses", "linux"]);
83
78 component.addOperation("Execute", 84 component.addOperation("Execute",
79 ["@SDKToolBinary@", "addTC", 85 ["@SDKToolBinary@", "addTC",
80 "--id", toolchainId + ".gcc", 86 "--id", toolchainId + ".gcc",
@@ -111,6 +117,7 @@ Component.prototype.createOperations = function()
111 "--name", platform + " " + target, 117 "--name", platform + " " + target,
112 "--type", "Qdb.EmbeddedLinuxQt", 118 "--type", "Qdb.EmbeddedLinuxQt",
113 "--qmake", path + "/sysroots/" + hostSysroot + "/usr/bin/qmake" + executableExt, 119 "--qmake", path + "/sysroots/" + hostSysroot + "/usr/bin/qmake" + executableExt,
120 "--abis", abi,
114 "UNDOEXECUTE", 121 "UNDOEXECUTE",
115 "@SDKToolBinary@", "rmQt", "--id", qtId]); 122 "@SDKToolBinary@", "rmQt", "--id", qtId]);
116 123
diff --git a/meta-boot2qt/recipes-qt/automotive/neptune3-ui_git.bb b/meta-boot2qt/recipes-qt/automotive/neptune3-ui_git.bb
index da0f658..ee26f08 100644
--- a/meta-boot2qt/recipes-qt/automotive/neptune3-ui_git.bb
+++ b/meta-boot2qt/recipes-qt/automotive/neptune3-ui_git.bb
@@ -31,7 +31,7 @@
31DESCRIPTION = "Neptune 3 IVI UI" 31DESCRIPTION = "Neptune 3 IVI UI"
32LICENSE = "Apache-2.0 & ( GPL-3.0 | The-Qt-Company-Commercial )" 32LICENSE = "Apache-2.0 & ( GPL-3.0 | The-Qt-Company-Commercial )"
33LIC_FILES_CHKSUM = "\ 33LIC_FILES_CHKSUM = "\
34 file://LICENSE.GPL3;md5=0d02f21f8e2533ecc519e2ed96bc94a2 \ 34 file://LICENSE.GPL3;md5=d32239bcb673463ab874e80d47fae504 \
35 file://imports_shared/assets/fonts/LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57 \ 35 file://imports_shared/assets/fonts/LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57 \
36" 36"
37 37
@@ -45,7 +45,7 @@ SRC_URI += " \
45 file://neptune.service \ 45 file://neptune.service \
46 " 46 "
47 47
48SRCREV = "c80d9aba17b1b50618ae6311d48f35ec726a4007" 48SRCREV = "be372dec5a64cdfc2b2ba66ea240d9fa1cdbe3eb"
49 49
50QMAKE_PROFILES = "${S}/neptune3-ui.pro" 50QMAKE_PROFILES = "${S}/neptune3-ui.pro"
51 51
diff --git a/meta-boot2qt/recipes-qt/automotive/qmllive_git.bb b/meta-boot2qt/recipes-qt/automotive/qmllive_git.bb
index 52cfcff..a0b49f6 100644
--- a/meta-boot2qt/recipes-qt/automotive/qmllive_git.bb
+++ b/meta-boot2qt/recipes-qt/automotive/qmllive_git.bb
@@ -30,14 +30,14 @@
30DESCRIPTION = "QML Live target runtime" 30DESCRIPTION = "QML Live target runtime"
31 31
32LICENSE = "GPL-3.0 | The-Qt-Company-Commercial" 32LICENSE = "GPL-3.0 | The-Qt-Company-Commercial"
33LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=75cd0dbc6f2d24e7eeb128ff59b74f4c" 33LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=d32239bcb673463ab874e80d47fae504"
34 34
35inherit qmake5 35inherit qmake5
36require recipes-qt/qt5/qt5-git.inc 36require recipes-qt/qt5/qt5-git.inc
37 37
38QT_GIT_PROJECT = "qt-apps" 38QT_GIT_PROJECT = "qt-apps"
39 39
40SRCREV = "329a996f6a52494ef677107593a0146c71a2880a" 40SRCREV = "dc83ea3bcbcfece8a0c5caeafcdd9f0854ffae6f"
41 41
42DEPENDS = "qtbase qtdeclarative" 42DEPENDS = "qtbase qtdeclarative"
43 43
diff --git a/meta-boot2qt/recipes-qt/automotive/qtapplicationmanager_git.bb b/meta-boot2qt/recipes-qt/automotive/qtapplicationmanager_git.bb
index c267e3f..7c81fc5 100644
--- a/meta-boot2qt/recipes-qt/automotive/qtapplicationmanager_git.bb
+++ b/meta-boot2qt/recipes-qt/automotive/qtapplicationmanager_git.bb
@@ -29,13 +29,13 @@
29 29
30DESCRIPTION = "Qt component for application lifecycle management" 30DESCRIPTION = "Qt component for application lifecycle management"
31LICENSE = "(GFDL-1.3 & The-Qt-Company-GPL-Exception-1.0 & (LGPL-3.0 | GPL-2.0+)) | The-Qt-Company-Commercial" 31LICENSE = "(GFDL-1.3 & The-Qt-Company-GPL-Exception-1.0 & (LGPL-3.0 | GPL-2.0+)) | The-Qt-Company-Commercial"
32LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=ff238b33ff354a0d8d79851a9c061717" 32LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=d32239bcb673463ab874e80d47fae504"
33 33
34inherit qt5-module 34inherit qt5-module
35require recipes-qt/qt5/qt5-git.inc 35require recipes-qt/qt5/qt5-git.inc
36 36
37QT_MODULE_BRANCH = "dev" 37QT_MODULE_BRANCH = "dev"
38SRCREV = "adb57812ee1cf89f3311f8a27ef97abf5d424bde" 38SRCREV = "9c4ff31161c2ea09c790ab143a23b3fe997ed4a3"
39 39
40DEPENDS = "qtbase qtdeclarative libyaml libarchive \ 40DEPENDS = "qtbase qtdeclarative libyaml libarchive \
41 ${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland qtwayland-native", "", d)}" 41 ${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland qtwayland-native", "", d)}"
diff --git a/meta-boot2qt/recipes-qt/automotive/qtivi_git.bb b/meta-boot2qt/recipes-qt/automotive/qtivi_git.bb
index 4b122c2..cb3f6a3 100644
--- a/meta-boot2qt/recipes-qt/automotive/qtivi_git.bb
+++ b/meta-boot2qt/recipes-qt/automotive/qtivi_git.bb
@@ -51,7 +51,7 @@ SRC_URI += " \
51 file://0001-Use-QT_HOST_BINS-get-for-getting-correct-path.patch \ 51 file://0001-Use-QT_HOST_BINS-get-for-getting-correct-path.patch \
52" 52"
53 53
54SRCREV_qtivi = "15a6672b304fe91a928911e810f5e83f233c790e" 54SRCREV_qtivi = "b18956edd578f49f369f7b3863881d0fadb035df"
55SRCREV_qface = "0a3ae7686e1100be452b8c435bdcd84ec242340e" 55SRCREV_qface = "0a3ae7686e1100be452b8c435bdcd84ec242340e"
56SRCREV = "${SRCREV_qtivi}" 56SRCREV = "${SRCREV_qtivi}"
57SRCREV_FORMAT = "qtivi_qface" 57SRCREV_FORMAT = "qtivi_qface"