summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaurice Kalinowski <maurice.kalinowski@qt.io>2018-02-06 11:04:39 +0100
committerMaurice Kalinowski <maurice.kalinowski@qt.io>2019-01-02 12:13:31 +0000
commit0f191b2fb735243df629b93e2bb1d7cc7e8c63fc (patch)
tree50ec3652c1b0937a61dbcc5369b0cb2768c8e590
parent0103760ff29668af74f40d3d344de48dbe920c63 (diff)
downloadmeta-boot2qt-0f191b2fb735243df629b93e2bb1d7cc7e8c63fc.tar.gz
Add Automation related modules and target
For OpcUA we are missing the backend libraries as they are not available upstream yet. However, building the Qt OpcUA module is a first step. Task-number: QTBUG-72001 Change-Id: I41cdce87d16b9a6dd15d381f1e0995ecac87b059 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
-rw-r--r--meta-boot2qt-distro/recipes-qt/images/b2qt-automation-qt5-image.bb55
-rw-r--r--meta-boot2qt-distro/recipes-qt/meta/meta-b2qt-automation-qbsp.bb50
-rw-r--r--meta-boot2qt-distro/recipes-qt/meta/meta-toolchain-b2qt-automation-qt5-sdk.bb39
-rw-r--r--meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-automation-addons.bb41
-rw-r--r--meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-automation-qt5-toolchain-target.bb42
5 files changed, 227 insertions, 0 deletions
diff --git a/meta-boot2qt-distro/recipes-qt/images/b2qt-automation-qt5-image.bb b/meta-boot2qt-distro/recipes-qt/images/b2qt-automation-qt5-image.bb
new file mode 100644
index 0000000..25bfb4d
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-qt/images/b2qt-automation-qt5-image.bb
@@ -0,0 +1,55 @@
1############################################################################
2##
3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "B2Qt Automation Qt5 image"
31LICENSE = "The-Qt-Company-Commercial"
32LIC_FILES_CHKSUM = "file://${QT_LICENSE};md5=948f8877345cd66106f11031977a4625"
33
34DEPLOY_CONF_TYPE = "Qt for Automation ($QT_VERSION)"
35
36IMAGE_FEATURES += "\
37 package-management \
38 ssh-server-dropbear \
39 tools-debug \
40 debug-tweaks \
41 hwcodecs \
42 "
43
44inherit core-image qbsp-image
45inherit consistent_timestamps
46
47IMAGE_INSTALL += "\
48 packagegroup-b2qt-embedded-base \
49 packagegroup-b2qt-embedded-tools \
50 ${@bb.utils.contains("DISTRO_FEATURES", "gstreamer010", "packagegroup-b2qt-embedded-gstreamer010", "", d)} \
51 ${@bb.utils.contains("DISTRO_FEATURES", "gstreamer", "packagegroup-b2qt-embedded-gstreamer", "", d)} \
52 packagegroup-b2qt-qt5-modules \
53 packagegroup-b2qt-embedded-addons \
54 packagegroup-b2qt-automation-addons \
55 "
diff --git a/meta-boot2qt-distro/recipes-qt/meta/meta-b2qt-automation-qbsp.bb b/meta-boot2qt-distro/recipes-qt/meta/meta-b2qt-automation-qbsp.bb
new file mode 100644
index 0000000..16a1530
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-qt/meta/meta-b2qt-automation-qbsp.bb
@@ -0,0 +1,50 @@
1############################################################################
2##
3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "Meta task for QBSP creation"
31
32LICENSE = "The-Qt-Company-Commercial"
33LIC_FILES_CHKSUM = "file://${QT_LICENSE};md5=948f8877345cd66106f11031977a4625"
34
35# get Qt version number
36require recipes-qt/qt5/qt5-git.inc
37S = "${WORKDIR}"
38
39inherit qbsp
40
41PV := "${@d.getVar('PV').split('+')[0]}"
42
43VERSION_SHORT = "${@d.getVar('PV').replace('.','')}"
44QBSP_NAME = "Automation ${PV}"
45QBSP_MACHINE = "${@d.getVar('MACHINE').replace('-','')}"
46QBSP_INSTALLER_COMPONENT = "automation.${VERSION_SHORT}.yocto.${QBSP_MACHINE}"
47QBSP_INSTALL_PATH = "/${PV}/Automation/${MACHINE}"
48
49QBSP_SDK_TASK = "meta-toolchain-b2qt-automation-qt5-sdk"
50QBSP_IMAGE_TASK = "b2qt-automation-qt5-image"
diff --git a/meta-boot2qt-distro/recipes-qt/meta/meta-toolchain-b2qt-automation-qt5-sdk.bb b/meta-boot2qt-distro/recipes-qt/meta/meta-toolchain-b2qt-automation-qt5-sdk.bb
new file mode 100644
index 0000000..8cd0d04
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-qt/meta/meta-toolchain-b2qt-automation-qt5-sdk.bb
@@ -0,0 +1,39 @@
1############################################################################
2##
3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "B2Qt embedded Qt5 SDK toolchain"
31
32LICENSE = "The-Qt-Company-Commercial"
33LIC_FILES_CHKSUM = "file://${QT_LICENSE};md5=948f8877345cd66106f11031977a4625"
34
35inherit populate_b2qt_qt5_sdk
36
37TOOLCHAIN_HOST_TASK += "nativesdk-packagegroup-b2qt-embedded-qt5-toolchain-host"
38TOOLCHAIN_TARGET_TASK += "packagegroup-b2qt-embedded-qt5-toolchain-target \
39 packagegroup-b2qt-automation-qt5-toolchain-target"
diff --git a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-automation-addons.bb b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-automation-addons.bb
new file mode 100644
index 0000000..d90e1b9
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-automation-addons.bb
@@ -0,0 +1,41 @@
1############################################################################
2##
3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "Automation specific Qt packages"
31LICENSE = "The-Qt-Company-Commercial"
32
33inherit packagegroup
34
35PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1"
36
37RDEPENDS_${PN} += " \
38 qtmqtt \
39 qtknx \
40 qtopcua \
41 "
diff --git a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-automation-qt5-toolchain-target.bb b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-automation-qt5-toolchain-target.bb
new file mode 100644
index 0000000..257ef0f
--- /dev/null
+++ b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-automation-qt5-toolchain-target.bb
@@ -0,0 +1,42 @@
1############################################################################
2##
3## Copyright (C) 2018 The Qt Company Ltd.
4## Contact: https://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:GPL$
9## Commercial License Usage
10## Licensees holding valid commercial Qt licenses may use this file in
11## accordance with the commercial license agreement provided with the
12## Software or, alternatively, in accordance with the terms contained in
13## a written agreement between you and The Qt Company. For licensing terms
14## and conditions see https://www.qt.io/terms-conditions. For further
15## information use the contact form at https://www.qt.io/contact-us.
16##
17## GNU General Public License Usage
18## Alternatively, this file may be used under the terms of the GNU
19## General Public License version 3 or (at your option) any later version
20## approved by the KDE Free Qt Foundation. The licenses are as published by
21## the Free Software Foundation and appearing in the file LICENSE.GPL3
22## included in the packaging of this file. Please review the following
23## information to ensure the GNU General Public License requirements will
24## be met: https://www.gnu.org/licenses/gpl-3.0.html.
25##
26## $QT_END_LICENSE$
27##
28############################################################################
29
30DESCRIPTION = "Target packages for B2Qt Automation Qt5 SDK"
31LICENSE = "The-Qt-Company-Commercial"
32PR = "r0"
33
34inherit packagegroup
35
36PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1"
37
38RDEPENDS_${PN} += " \
39 qtmqtt-dev \
40 qtknx-dev \
41 qtopcua-dev \
42 "