summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2016-02-23 13:23:56 +0200
committerSamuli Piippo <samuli.piippo@theqtcompany.com>2016-02-24 09:42:12 +0000
commit0d5594111ea1712f731cff174f21b3e2c4246c15 (patch)
tree341021629532e54e679c05de8fedf4fe030b4b2d
parenteb86db52fda9ef2c88312172e4608993104d3b00 (diff)
downloadmeta-boot2qt-0d5594111ea1712f731cff174f21b3e2c4246c15.tar.gz
kontron: update to Yocto BSP for SMARC-sAMX6i R02.00
Change-Id: If0f8dc2c786bc63fba69531fa009efd8ae8111b7 Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
-rwxr-xr-xb2qt-init-build-env5
-rw-r--r--conf/bblayers.conf.smx6.sample50
-rw-r--r--conf/distro/include/smarc-samx6i.conf3
-rw-r--r--meta-smx6-extras/conf/layer.conf37
-rw-r--r--meta-smx6-extras/recipes/linux/linux-smx6_3.14.28.bbappend26
-rw-r--r--scripts/manifest.xml10
-rw-r--r--scripts/manifest_fido.xml7
-rwxr-xr-xscripts/setup-environment.sh5
8 files changed, 138 insertions, 5 deletions
diff --git a/b2qt-init-build-env b/b2qt-init-build-env
index e3c619b..90fa2b0 100755
--- a/b2qt-init-build-env
+++ b/b2qt-init-build-env
@@ -95,9 +95,12 @@ get_groups() {
95 apalis-imx6|colibri-imx6|colibri-vf) 95 apalis-imx6|colibri-imx6|colibri-vf)
96 PROJECT_GROUPS="toradex" 96 PROJECT_GROUPS="toradex"
97 ;; 97 ;;
98 imx53qsb|imx6qsabresd|imx6dlsabresd|nitrogen6x|smarc-samx6i) 98 imx53qsb|imx6qsabresd|imx6dlsabresd|nitrogen6x)
99 PROJECT_GROUPS="fsl" 99 PROJECT_GROUPS="fsl"
100 ;; 100 ;;
101 smarc-samx6i)
102 PROJECT_GROUPS="smx6"
103 ;;
101 tibidabo) 104 tibidabo)
102 PROJECT_GROUPS="architech" 105 PROJECT_GROUPS="architech"
103 ;; 106 ;;
diff --git a/conf/bblayers.conf.smx6.sample b/conf/bblayers.conf.smx6.sample
new file mode 100644
index 0000000..f604394
--- /dev/null
+++ b/conf/bblayers.conf.smx6.sample
@@ -0,0 +1,50 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22# LAYER_CONF_VERSION is increased each time build/conf/bblayers.conf
23# changes incompatibly
24LCONF_VERSION = "6"
25
26BBPATH = "${TOPDIR}"
27BBFILES ?= ""
28BSPDIR := "${@os.path.abspath(os.path.dirname(d.getVar('FILE', True)) + '/../..')}"
29
30BBLAYERS ?= " \
31 ${BSPDIR}/sources/poky/meta \
32 ${BSPDIR}/sources/poky/meta-yocto \
33 ${BSPDIR}/sources/meta-fsl-arm \
34 ${BSPDIR}/sources/meta-fsl-arm-extra \
35 ${BSPDIR}/sources/meta-smx6 \
36 ${BSPDIR}/sources/meta-openembedded/meta-oe \
37 ${BSPDIR}/sources/meta-openembedded/meta-python \
38 ${BSPDIR}/sources/meta-openembedded/meta-networking \
39 ${BSPDIR}/sources/meta-openembedded/meta-initramfs \
40 ${BSPDIR}/sources/meta-openembedded/meta-ruby \
41 ${BSPDIR}/sources/meta-b2qt \
42 ${BSPDIR}/sources/meta-b2qt/meta-fsl-extras \
43 ${BSPDIR}/sources/meta-b2qt/meta-smx6-extras \
44 ${BSPDIR}/sources/meta-mingw \
45 ${BSPDIR}/sources/meta-qt5 \
46 "
47BBLAYERS_NON_REMOVABLE ?= " \
48 ${BSPDIR}/sources/poky/meta \
49 ${BSPDIR}/sources/poky/meta-yocto \
50 "
diff --git a/conf/distro/include/smarc-samx6i.conf b/conf/distro/include/smarc-samx6i.conf
index 23bc85f..d3ce2c9 100644
--- a/conf/distro/include/smarc-samx6i.conf
+++ b/conf/distro/include/smarc-samx6i.conf
@@ -45,3 +45,6 @@ MACHINE_EXTRA_INSTALL_SDK += " \
45 " 45 "
46 46
47KERNEL_MODULE_AUTOLOAD += "mxc_v4l2_capture" 47KERNEL_MODULE_AUTOLOAD += "mxc_v4l2_capture"
48
49BBMASK ?= " "
50BBMASK .= "|meta-smx6/recipes-qt"
diff --git a/meta-smx6-extras/conf/layer.conf b/meta-smx6-extras/conf/layer.conf
new file mode 100644
index 0000000..097fefe
--- /dev/null
+++ b/meta-smx6-extras/conf/layer.conf
@@ -0,0 +1,37 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22# We have a conf and classes directory, append to BBPATH
23BBPATH .= ":${LAYERDIR}"
24
25# We have a recipes directory, add to BBFILES
26BBFILES += "${LAYERDIR}/recipes*/*/*.bb \
27 ${LAYERDIR}/recipes*/*/*.bbappend \
28 "
29
30BBFILE_COLLECTIONS += "b2qt_smx6"
31BBFILE_PATTERN_b2qt_smx6 := "^${LAYERDIR}/"
32BBFILE_PRIORITY_b2qt_smx6 = "20"
33
34# meta-smx6 depends on fsl-demos, but that's not needed
35LAYERDEPENDS_smx6 = ""
36# meta-smx6 layer.conf modifies qtbase PACKAGECONFIG
37PACKAGECONFIG_remove_pn-qtbase = "examples"
diff --git a/meta-smx6-extras/recipes/linux/linux-smx6_3.14.28.bbappend b/meta-smx6-extras/recipes/linux/linux-smx6_3.14.28.bbappend
new file mode 100644
index 0000000..00f3c11
--- /dev/null
+++ b/meta-smx6-extras/recipes/linux/linux-smx6_3.14.28.bbappend
@@ -0,0 +1,26 @@
1##############################################################################
2##
3## Copyright (C) 2016 The Qt Company Ltd.
4## Contact: http://www.qt.io/licensing/
5##
6## This file is part of the Boot to Qt meta layer.
7##
8## $QT_BEGIN_LICENSE:COMM$
9##
10## Commercial License Usage
11## Licensees holding valid commercial Qt licenses may use this file in
12## accordance with the commercial license agreement provided with the
13## Software or, alternatively, in accordance with the terms contained in
14## a written agreement between you and The Qt Company. For licensing terms
15## and conditions see http://www.qt.io/terms-conditions. For further
16## information use the contact form at http://www.qt.io/contact-us.
17##
18## $QT_END_LICENSE$
19##
20##############################################################################
21
22do_configure_prepend() {
23 echo "CONFIG_NAMESPACES=y" >> ${WORKDIR}/defconfig
24 echo "CONFIG_FHANDLE=y" >> ${WORKDIR}/defconfig
25 echo "CONFIG_CGROUPS=y" >> ${WORKDIR}/defconfig
26}
diff --git a/scripts/manifest.xml b/scripts/manifest.xml
index 703aedc..71686c1 100644
--- a/scripts/manifest.xml
+++ b/scripts/manifest.xml
@@ -37,7 +37,7 @@
37 remote="yocto" 37 remote="yocto"
38 revision="c9f259a4bf8472dfa3ff75f1c3fcbe5e0ded7aaf" 38 revision="c9f259a4bf8472dfa3ff75f1c3fcbe5e0ded7aaf"
39 path="sources/meta-fsl-arm" 39 path="sources/meta-fsl-arm"
40 groups="notdefault,fsl,toradex,architech,ti,bbb"/> 40 groups="notdefault,fsl,toradex,architech,ti,bbb,smx6"/>
41 <project name="meta-ti" 41 <project name="meta-ti"
42 remote="yocto" 42 remote="yocto"
43 revision="0a222c70845d19a2213ac36803361e8531768cca" 43 revision="0a222c70845d19a2213ac36803361e8531768cca"
@@ -52,7 +52,7 @@
52 remote="freescale" 52 remote="freescale"
53 revision="ad90ca98459f5de9483bb3ba5a81be0a67b078c3" 53 revision="ad90ca98459f5de9483bb3ba5a81be0a67b078c3"
54 path="sources/meta-fsl-arm-extra" 54 path="sources/meta-fsl-arm-extra"
55 groups="notdefault,fsl,toradex,architech"/> 55 groups="notdefault,fsl,toradex,architech,smx6"/>
56 <project name="meta-beagleboard" 56 <project name="meta-beagleboard"
57 remote="beagleboard" 57 remote="beagleboard"
58 revision="b5c709b2b6bd3bf236df923fa8f245a00fbb1b60" 58 revision="b5c709b2b6bd3bf236df923fa8f245a00fbb1b60"
@@ -73,6 +73,7 @@
73 revision="ead0a5c115e632015d8358f4f304ec8908732f5f" 73 revision="ead0a5c115e632015d8358f4f304ec8908732f5f"
74 path="sources/meta-intel" 74 path="sources/meta-intel"
75 groups="notdefault,nuc"/> 75 groups="notdefault,nuc"/>
76
76 <project name="meta-tegra" 77 <project name="meta-tegra"
77 remote="playground" 78 remote="playground"
78 revision="3125d29a5c58a471b67104d1bff965df38eb3115" 79 revision="3125d29a5c58a471b67104d1bff965df38eb3115"
@@ -83,6 +84,11 @@
83 revision="a376c795d5361fda4ea5f19feecc23ab7e753646" 84 revision="a376c795d5361fda4ea5f19feecc23ab7e753646"
84 path="sources/jetson-tk1-pro" 85 path="sources/jetson-tk1-pro"
85 groups="notdefault,nvidia-logan"/> 86 groups="notdefault,nvidia-logan"/>
87 <project name="meta-smx6"
88 remote="playground"
89 revision="c2f639ef4b2fd5809ab95fb330d28c2716aa290d"
90 path="sources/meta-smx6"
91 groups="notdefault,smx6"/>
86 92
87</manifest> 93</manifest>
88 94
diff --git a/scripts/manifest_fido.xml b/scripts/manifest_fido.xml
index 2945e88..3a13f40 100644
--- a/scripts/manifest_fido.xml
+++ b/scripts/manifest_fido.xml
@@ -73,6 +73,7 @@
73 revision="fido" 73 revision="fido"
74 path="sources/meta-intel" 74 path="sources/meta-intel"
75 groups="notdefault,nuc"/> 75 groups="notdefault,nuc"/>
76
76 <project name="meta-tegra" 77 <project name="meta-tegra"
77 remote="playground" 78 remote="playground"
78 revision="master" 79 revision="master"
@@ -83,6 +84,10 @@
83 revision="master" 84 revision="master"
84 path="sources/jetson-tk1-pro" 85 path="sources/jetson-tk1-pro"
85 groups="notdefault,nvidia-logan"/> 86 groups="notdefault,nvidia-logan"/>
86 87 <project name="meta-smx6"
88 remote="playground"
89 revision="fido"
90 path="sources/meta-smx6"
91 groups="notdefault,smx6"/>
87</manifest> 92</manifest>
88 93
diff --git a/scripts/setup-environment.sh b/scripts/setup-environment.sh
index f681d14..28adeec 100755
--- a/scripts/setup-environment.sh
+++ b/scripts/setup-environment.sh
@@ -51,9 +51,12 @@ if [ ! -f ${PWD}/${BUILDDIRECTORY}/conf/bblayers.conf ]; then
51 apalis-imx6|colibri-imx6|colibri-vf) 51 apalis-imx6|colibri-imx6|colibri-vf)
52 LAYERSCONF="bblayers.conf.toradex.sample" 52 LAYERSCONF="bblayers.conf.toradex.sample"
53 ;; 53 ;;
54 imx53qsb|imx6qsabresd|imx6dlsabresd|nitrogen6x|smarc-samx6i) 54 imx53qsb|imx6qsabresd|imx6dlsabresd|nitrogen6x)
55 LAYERSCONF="bblayers.conf.fsl.sample" 55 LAYERSCONF="bblayers.conf.fsl.sample"
56 ;; 56 ;;
57 smarc-samx6i)
58 LAYERSCONF="bblayers.conf.smx6.sample"
59 ;;
57 tibidabo) 60 tibidabo)
58 LAYERSCONF="bblayers.conf.tibidabo.sample" 61 LAYERSCONF="bblayers.conf.tibidabo.sample"
59 ;; 62 ;;