summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/u-boot/files/v2016.11/de0-nano-soc.env11
-rw-r--r--recipes-bsp/u-boot/u-boot-mkenvimage_v2016.11.bb23
-rw-r--r--recipes-bsp/u-boot/u-boot-socfpga-env.inc25
-rw-r--r--recipes-bsp/u-boot/u-boot-socfpga_v2016.05.bb2
-rw-r--r--recipes-bsp/u-boot/u-boot-socfpga_v2016.11.bb6
5 files changed, 66 insertions, 1 deletions
diff --git a/recipes-bsp/u-boot/files/v2016.11/de0-nano-soc.env b/recipes-bsp/u-boot/files/v2016.11/de0-nano-soc.env
new file mode 100644
index 0000000..0e81fa3
--- /dev/null
+++ b/recipes-bsp/u-boot/files/v2016.11/de0-nano-soc.env
@@ -0,0 +1,11 @@
1baudrate=115200
2bootargs=console=ttyS0,115200
3bootcmd=run mmcload; run mmcboot
4fdtimage=socfpga_cyclone5_de0_sockit.dtb
5bootimage=zImage
6fdt_addr=100
7loadaddr=0x01000000
8mmcboot=setenv bootargs console=ttyS0,115200 root=${mmcroot} rw rootwait;bootz ${loadaddr} - ${fdt_addr}
9mmcload=mmc rescan;load mmc 0:2 ${loadaddr} ${bootimage};load mmc 0:2 ${fdt_addr} ${fdtimage}
10mmcroot=/dev/mmcblk0p3
11ramboot=setenv bootargs console=ttyS0,115200;bootm ${loadaddr} - ${fdt_addr}
diff --git a/recipes-bsp/u-boot/u-boot-mkenvimage_v2016.11.bb b/recipes-bsp/u-boot/u-boot-mkenvimage_v2016.11.bb
new file mode 100644
index 0000000..cab156a
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-mkenvimage_v2016.11.bb
@@ -0,0 +1,23 @@
1SUMMARY = "U-Boot bootloader environment image creation tool"
2
3require u-boot-socfpga-common.inc
4
5# This revision corresponds to the tag "v2016.11"
6# We use the revision in order to avoid having to fetch it from the
7# repo during parse
8SRCREV = "29e0cfb4f77f7aa369136302cee14a91e22dca71"
9
10EXTRA_OEMAKE = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" STRIP=true V=1'
11
12do_compile () {
13 oe_runmake sandbox_defconfig
14 oe_runmake cross_tools NO_SDL=1
15}
16
17do_install () {
18 install -d ${D}${bindir}
19 install -m 0755 tools/mkenvimage ${D}${bindir}/uboot-mkenvimage
20 ln -sf uboot-mkenvimage ${D}${bindir}/mkenvimage
21}
22
23BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-bsp/u-boot/u-boot-socfpga-env.inc b/recipes-bsp/u-boot/u-boot-socfpga-env.inc
new file mode 100644
index 0000000..55621b9
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-socfpga-env.inc
@@ -0,0 +1,25 @@
1DEPENDS += "u-boot-mkenvimage-native"
2
3#Env binary size
4ENV_SIZE = "4096"
5
6#Env base Name
7ENV_BASE_NAME ??= "${UBOOT_CONFIG}"
8
9# Env base file correspond to common part of all environment
10ENV_BASE_FILE = "${WORKDIR}/${ENV_BASE_NAME}.env"
11
12do_environment_mkimage() {
13 if [ -e ${WORKDIR}/${PV}/${ENV_BASE_NAME}.env ]; then
14 mkenvimage -s ${ENV_SIZE} -o ${WORKDIR}/${ENV_BASE_NAME}.bin ${WORKDIR}/${PV}/${ENV_BASE_NAME}.env
15 fi
16}
17
18do_deploy_append() {
19 if [ -e ${WORKDIR}/${ENV_BASE_NAME}.bin]; then
20 install -d ${DEPLOYDIR}
21 install -m 644 ${WORKDIR}/${ENV_BASE_NAME}.bin ${DEPLOYDIR}/u-boot-env-${ENV_BASE_NAME}.bin
22 fi
23}
24
25addtask environment_mkimage after do_compile before do_deploy
diff --git a/recipes-bsp/u-boot/u-boot-socfpga_v2016.05.bb b/recipes-bsp/u-boot/u-boot-socfpga_v2016.05.bb
index 40281cb..526e22c 100644
--- a/recipes-bsp/u-boot/u-boot-socfpga_v2016.05.bb
+++ b/recipes-bsp/u-boot/u-boot-socfpga_v2016.05.bb
@@ -5,5 +5,5 @@ require ${COREBASE}/meta/recipes-bsp/u-boot/u-boot.inc
5# We use the revision in order to avoid having to fetch it from the 5# We use the revision in order to avoid having to fetch it from the
6# repo during parse 6# repo during parse
7SRCREV = "aeaec0e682f45b9e0c62c522fafea353931f73ed" 7SRCREV = "aeaec0e682f45b9e0c62c522fafea353931f73ed"
8 8PR = "r1"
9DEPENDS += "dtc-native" 9DEPENDS += "dtc-native"
diff --git a/recipes-bsp/u-boot/u-boot-socfpga_v2016.11.bb b/recipes-bsp/u-boot/u-boot-socfpga_v2016.11.bb
index 0204422..356f88a 100644
--- a/recipes-bsp/u-boot/u-boot-socfpga_v2016.11.bb
+++ b/recipes-bsp/u-boot/u-boot-socfpga_v2016.11.bb
@@ -1,4 +1,5 @@
1require u-boot-socfpga-common.inc 1require u-boot-socfpga-common.inc
2require u-boot-socfpga-env.inc
2require ${COREBASE}/meta/recipes-bsp/u-boot/u-boot.inc 3require ${COREBASE}/meta/recipes-bsp/u-boot/u-boot.inc
3 4
4# This revision corresponds to the tag "v2016.11" 5# This revision corresponds to the tag "v2016.11"
@@ -6,4 +7,9 @@ require ${COREBASE}/meta/recipes-bsp/u-boot/u-boot.inc
6# repo during parse 7# repo during parse
7SRCREV = "29e0cfb4f77f7aa369136302cee14a91e22dca71" 8SRCREV = "29e0cfb4f77f7aa369136302cee14a91e22dca71"
8 9
10SRC_URI_append = "\
11 file://v2016.11/de0-nano-soc.env \
12 "
13PR = "r1"
14
9DEPENDS += "dtc-native" 15DEPENDS += "dtc-native"