summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-socfpga_v2013.01.01.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-socfpga_v2013.01.01.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-socfpga_v2013.01.01.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-socfpga_v2013.01.01.bb b/recipes-bsp/u-boot/u-boot-socfpga_v2013.01.01.bb
new file mode 100644
index 0000000..449f6c3
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-socfpga_v2013.01.01.bb
@@ -0,0 +1,23 @@
1require ${COREBASE}/meta/recipes-bsp/u-boot/u-boot.inc
2PR="r1"
3
4SRCREV = "95ab599e1ad7840e08be0aa567eea3fca357572f"
5
6UBOOT_BRANCH ?= "socfpga_${PV}"
7UBOOT_REPO ?= "git://github.com/altera-opensource/u-boot-socfpga.git"
8UBOOT_PROT ?= "https"
9
10SRC_URI = "\
11 ${UBOOT_REPO};protocol=${UBOOT_PROT};branch=${UBOOT_BRANCH} \
12 file://fix-build-error-under-gcc6.patch \
13 "
14
15LICENSE = "GPLv2+"
16LIC_FILES_CHKSUM = "file://README;md5=176c127db28f1a9e8d88f682a2a34963"
17
18DEPENDS += "dtc-native"
19
20UBOOT_CONFIG[cyclone5-socdk] = "socfpga_cyclone5_config"
21
22SPL_BINARY_cyclone5 = "spl/u-boot-spl.bin"
23SPL_BINARY_arria5 = "spl/u-boot-spl.bin"