summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-mkenvimage_v2016.11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-mkenvimage_v2016.11.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-mkenvimage_v2016.11.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-mkenvimage_v2016.11.bb b/recipes-bsp/u-boot/u-boot-mkenvimage_v2016.11.bb
new file mode 100644
index 0000000..cab156a
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-mkenvimage_v2016.11.bb
@@ -0,0 +1,23 @@
1SUMMARY = "U-Boot bootloader environment image creation tool"
2
3require u-boot-socfpga-common.inc
4
5# This revision corresponds to the tag "v2016.11"
6# We use the revision in order to avoid having to fetch it from the
7# repo during parse
8SRCREV = "29e0cfb4f77f7aa369136302cee14a91e22dca71"
9
10EXTRA_OEMAKE = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" STRIP=true V=1'
11
12do_compile () {
13 oe_runmake sandbox_defconfig
14 oe_runmake cross_tools NO_SDL=1
15}
16
17do_install () {
18 install -d ${D}${bindir}
19 install -m 0755 tools/mkenvimage ${D}${bindir}/uboot-mkenvimage
20 ln -sf uboot-mkenvimage ${D}${bindir}/mkenvimage
21}
22
23BBCLASSEXTEND = "native nativesdk"