summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/u-boot/files/v2017.07/cyclone5-socdk.env11
-rw-r--r--recipes-bsp/u-boot/files/v2017.07/de0-nano-soc.env11
-rw-r--r--recipes-bsp/u-boot/u-boot-socfpga_v2017.07.bb17
3 files changed, 39 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/files/v2017.07/cyclone5-socdk.env b/recipes-bsp/u-boot/files/v2017.07/cyclone5-socdk.env
new file mode 100644
index 0000000..983149f
--- /dev/null
+++ b/recipes-bsp/u-boot/files/v2017.07/cyclone5-socdk.env
@@ -0,0 +1,11 @@
1baudrate=115200
2bootargs=console=ttyS0,115200
3bootcmd=run mmcload; run mmcboot
4fdtimage=socfpga_cyclone5_socdk.dtb
5bootimage=zImage
6fdt_addr=100
7loadaddr=0x01000000
8mmcboot=setenv bootargs console=ttyS0,115200 root=${mmcroot} rw rootwait;bootz ${loadaddr} - ${fdt_addr}
9mmcload=mmc rescan;load mmc 0:1 ${loadaddr} ${bootimage};load mmc 0:1 ${fdt_addr} ${fdtimage}
10mmcroot=/dev/mmcblk0p2
11ramboot=setenv bootargs console=ttyS0,115200;bootm ${loadaddr} - ${fdt_addr}
diff --git a/recipes-bsp/u-boot/files/v2017.07/de0-nano-soc.env b/recipes-bsp/u-boot/files/v2017.07/de0-nano-soc.env
new file mode 100644
index 0000000..3c28f0f
--- /dev/null
+++ b/recipes-bsp/u-boot/files/v2017.07/de0-nano-soc.env
@@ -0,0 +1,11 @@
1baudrate=115200
2bootargs=console=ttyS0,115200
3bootcmd=run mmcload; run mmcboot
4fdtimage=socfpga_cyclone5_de0_sockit.dtb
5bootimage=zImage
6fdt_addr=100
7loadaddr=0x01000000
8mmcboot=setenv bootargs console=ttyS0,115200 root=${mmcroot} rw rootwait;bootz ${loadaddr} - ${fdt_addr}
9mmcload=mmc rescan;load mmc 0:1 ${loadaddr} ${bootimage};load mmc 0:1 ${fdt_addr} ${fdtimage}
10mmcroot=/dev/mmcblk0p2
11ramboot=setenv bootargs console=ttyS0,115200;bootm ${loadaddr} - ${fdt_addr}
diff --git a/recipes-bsp/u-boot/u-boot-socfpga_v2017.07.bb b/recipes-bsp/u-boot/u-boot-socfpga_v2017.07.bb
new file mode 100644
index 0000000..635acee
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-socfpga_v2017.07.bb
@@ -0,0 +1,17 @@
1require u-boot-socfpga-common.inc
2require u-boot-socfpga-env.inc
3require ${COREBASE}/meta/recipes-bsp/u-boot/u-boot.inc
4
5FILESEXTRAPATHS =. "${THISDIR}/files/v2017.07:"
6
7# This revision corresponds to the tag "v2017.07"
8# We use the revision in order to avoid having to fetch it from the
9# repo during parse
10SRCREV = "d85ca029f257b53a96da6c2fb421e78a003a9943"
11
12SRC_URI_append = "\
13 file://de0-nano-soc.env \
14 file://cyclone5-socdk.env \
15 "
16
17DEPENDS += "dtc-native bc-native u-boot-mkimage-native"