summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorDalon Westergreen <dalon.westergreen@intel.com>2017-01-11 10:16:43 -0800
committerKhem Raj <raj.khem@gmail.com>2017-01-11 10:16:43 -0800
commit0c6e036fdfec58b69903a10e886a9dfae8fe4c9f (patch)
treed20289b0fe29ddea1e637248a68e2d0f7c20a89e /recipes-bsp
parentab2ee2812670be650d6a722de08dff9bf05131f8 (diff)
downloadmeta-altera-0c6e036fdfec58b69903a10e886a9dfae8fe4c9f.tar.gz
Update uboot and kernel recipes, and fix sdcard class (#44)
* u-boot-socfpga: update PV for all recipes and add common include for mainline uboot versions u-boot-socfpga versioning scheme varied, some prepended with a 'v' others not. u-boot mainline tags versions with vYYYY.MM so we should be consistent. Create a single include for all mainline uboot versions. Signed-off-by: Dalon Westergreen <dwesterg@gmail.com> * u-boot-socfpga: Add support for v2016.11 Signed-off-by: Dalon Westergreen <dwesterg@gmail.com> * Update sdcard image class and add to arria5 / cyclone 5 machine conf * Move arria5/cyclone5 to uboot-socfpga v2016.11 Signed-off-by: Dalon Westergreen <dwesterg@gmail.com> * Update sdcard script Seemed to be an issue with the rootfs partition being slightly smaller then the ROOTFS_SIZE in some cases. Signed-off-by: Dalon Westergreen <dalon.westergreen@intel.com> * uboot: Cleanup v2014.10 recipe v2014.10 is used for Arria10, at this time it does not support GCC6 which is the default for morty * Clean up arria5 and cyclone5 machine definitions Signed-off-by: Dalon Westergreen <dalon.westergreen@intel.com> * linux-socfpga: add 4.7 and 4.7 dev recipes Signed-off-by: Dalon Westergreen <dalon.westergreen@intel.com> * linux-socfpga: update srcrev for 4.6 kernel and remove 4.6 dev Signed-off-by: Dalon Westergreen <dalon.westergreen@intel.com> * linux-socfpga: delete 4.1 dev as 4.1 is no longer maintained * linux-socfpga: update 4.1.22 srcrev to latest release
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/u-boot/u-boot-socfpga-common.inc (renamed from recipes-bsp/u-boot/u-boot-common_2016.05.inc)7
-rw-r--r--recipes-bsp/u-boot/u-boot-socfpga_2014.10.bb50
-rw-r--r--recipes-bsp/u-boot/u-boot-socfpga_v2014.10.bb18
-rw-r--r--recipes-bsp/u-boot/u-boot-socfpga_v2016.05.bb (renamed from recipes-bsp/u-boot/u-boot-socfpga_2016.05.bb)7
-rw-r--r--recipes-bsp/u-boot/u-boot-socfpga_v2016.11.bb10
5 files changed, 35 insertions, 57 deletions
diff --git a/recipes-bsp/u-boot/u-boot-common_2016.05.inc b/recipes-bsp/u-boot/u-boot-socfpga-common.inc
index 985e221..d0f1723 100644
--- a/recipes-bsp/u-boot/u-boot-common_2016.05.inc
+++ b/recipes-bsp/u-boot/u-boot-socfpga-common.inc
@@ -4,12 +4,7 @@ SECTION = "bootloaders"
4LICENSE = "GPLv2+" 4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6" 5LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
6 6
7# This revision corresponds to the tag "v2016.05" 7PV_append = "+git${SRCPV}"
8# We use the revision in order to avoid having to fetch it from the
9# repo during parse
10SRCREV = "aeaec0e682f45b9e0c62c522fafea353931f73ed"
11
12PV = "v2016.05+git${SRCPV}"
13 8
14SRC_URI = "git://git.denx.de/u-boot.git;branch=master" 9SRC_URI = "git://git.denx.de/u-boot.git;branch=master"
15 10
diff --git a/recipes-bsp/u-boot/u-boot-socfpga_2014.10.bb b/recipes-bsp/u-boot/u-boot-socfpga_2014.10.bb
deleted file mode 100644
index 7ee2a5c..0000000
--- a/recipes-bsp/u-boot/u-boot-socfpga_2014.10.bb
+++ /dev/null
@@ -1,50 +0,0 @@
1UBOOT_SUFFIX ?= "img"
2UBOOT_RAW_BINARY ?= "u-boot-dtb.bin"
3UBOOT_DTB ?= "u-boot.dtb"
4
5require ${COREBASE}/meta/recipes-bsp/u-boot/u-boot.inc
6
7FILESEXTRAPATHS_prepend := "${THISDIR}/u-boot:"
8
9LICENSE = "GPLv2+"
10LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
11
12PACKAGE_ARCH = "${MACHINE_ARCH}"
13
14PROVIDES += "u-boot"
15PKG_${PN} = "u-boot"
16PKG_${PN}-dev = "u-boot-dev"
17PKG_${PN}-dbg = "u-boot-dbg"
18
19S = "${WORKDIR}/git"
20
21# SPL (Second Program Loader) to be loaded over UART
22SPL_UART_BINARY ?= ""
23SPL_UART_IMAGE ?= "${SPL_UART_BINARY}-${MACHINE}-${PV}-${PR}"
24SPL_UART_SYMLINK ?= "${SPL_UART_BINARY}-${MACHINE}"
25
26do_deploy_append () {
27 install ${S}/${UBOOT_RAW_BINARY} ${DEPLOYDIR}/${UBOOT_RAW_BINARY}
28 install ${S}/${UBOOT_DTB} ${DEPLOYDIR}/${UBOOT_DTB}
29}
30
31# DEPEND on dtc-native for mainline u-boot because the mainline u-boot depends
32# on some of the latest syntax constructs for an appended in dtb used for
33# items like secure boot/image signing.
34DEPENDS += "dtc-native"
35
36DESCRIPTION = "Mainline u-boot bootloader"
37
38LIC_FILES_CHKSUM = "file://Licenses/README;md5=c7383a594871c03da76b3707929d2919"
39
40PV = "2014.10"
41
42UBOOT_BRANCH ?= "socfpga_v${PV}_arria10_bringup"
43UBOOT_REPO ?= "git://github.com/altera-opensource/u-boot-socfpga.git"
44UBOOT_PROT ?= "https"
45
46SRC_URI = "${UBOOT_REPO};protocol=${UBOOT_PROT};branch=${UBOOT_BRANCH}"
47
48#SoCEDS 15.1 release
49SRCREV = "2c7fd1aac5f06ceea822c4d6a8af9ea2b11fdfd4"
50
diff --git a/recipes-bsp/u-boot/u-boot-socfpga_v2014.10.bb b/recipes-bsp/u-boot/u-boot-socfpga_v2014.10.bb
new file mode 100644
index 0000000..5c82261
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-socfpga_v2014.10.bb
@@ -0,0 +1,18 @@
1require ${COREBASE}/meta/recipes-bsp/u-boot/u-boot.inc
2PR="r1"
3# This revision corresponds to the SoCEDS 16.1 release
4SRCREV = "ab2181dd766157a74b309d12e0b61c4f3cdc8564"
5
6UBOOT_BRANCH ?= "socfpga_${PV}_arria10_bringup"
7UBOOT_REPO ?= "git://github.com/altera-opensource/u-boot-socfpga.git"
8UBOOT_PROT ?= "https"
9
10SRC_URI = "${UBOOT_REPO};protocol=${UBOOT_PROT};branch=${UBOOT_BRANCH}"
11
12LICENSE = "GPLv2+"
13LIC_FILES_CHKSUM = "file://Licenses/README;md5=c7383a594871c03da76b3707929d2919"
14
15DEPENDS += "dtc-native"
16
17UBOOT_BINARY = "u-boot-dtb.bin"
18
diff --git a/recipes-bsp/u-boot/u-boot-socfpga_2016.05.bb b/recipes-bsp/u-boot/u-boot-socfpga_v2016.05.bb
index 8f5e038..a4e1f44 100644
--- a/recipes-bsp/u-boot/u-boot-socfpga_2016.05.bb
+++ b/recipes-bsp/u-boot/u-boot-socfpga_v2016.05.bb
@@ -1,6 +1,11 @@
1require u-boot-common_${PV}.inc 1require u-boot-socfpga-common.inc
2require ${COREBASE}/meta/recipes-bsp/u-boot/u-boot.inc 2require ${COREBASE}/meta/recipes-bsp/u-boot/u-boot.inc
3 3
4# This revision corresponds to the tag "v2016.05"
5# We use the revision in order to avoid having to fetch it from the
6# repo during parse
7SRCREV = "aeaec0e682f45b9e0c62c522fafea353931f73ed"
8
4DEPENDS += "dtc-native" 9DEPENDS += "dtc-native"
5 10
6do_install_append_10m50 () { 11do_install_append_10m50 () {
diff --git a/recipes-bsp/u-boot/u-boot-socfpga_v2016.11.bb b/recipes-bsp/u-boot/u-boot-socfpga_v2016.11.bb
new file mode 100644
index 0000000..e0eb0cd
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-socfpga_v2016.11.bb
@@ -0,0 +1,10 @@
1require u-boot-socfpga-common.inc
2require ${COREBASE}/meta/recipes-bsp/u-boot/u-boot.inc
3
4# This revision corresponds to the tag "v2016.11"
5# We use the revision in order to avoid having to fetch it from the
6# repo during parse
7SRCREV = "29e0cfb4f77f7aa369136302cee14a91e22dca71"
8
9DEPENDS += "dtc-native"
10