summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-11-13 13:21:01 -0800
committerKhem Raj <raj.khem@gmail.com>2015-11-13 13:21:01 -0800
commit2ba2ed062239cb5c151d938eae4cee81ecfd395b (patch)
tree80f5b589a310a8df8f5fda4fae273ec99bd6a89d /recipes-bsp/u-boot
parent996b8127c431472cf35b691e8d1c9f0cc79a0650 (diff)
parenta70aac4f9859549ae2f5984d5b02dfd3f1f29289 (diff)
downloadmeta-altera-2ba2ed062239cb5c151d938eae4cee81ecfd395b.tar.gz
Merge pull request #4 from dwesterg/master
Update Meta-altera
Diffstat (limited to 'recipes-bsp/u-boot')
-rwxr-xr-xrecipes-bsp/u-boot/u-boot-socfpga_2013.01.01.bb3
-rwxr-xr-xrecipes-bsp/u-boot/u-boot-socfpga_2014.10.bb50
2 files changed, 53 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-socfpga_2013.01.01.bb b/recipes-bsp/u-boot/u-boot-socfpga_2013.01.01.bb
index 1beca44..f2f4328 100755
--- a/recipes-bsp/u-boot/u-boot-socfpga_2013.01.01.bb
+++ b/recipes-bsp/u-boot/u-boot-socfpga_2013.01.01.bb
@@ -1 +1,4 @@
1# SoCEDS 15.1 u-Boot release
2UBOOT_TAG = "353283b6e75eabdcc48dadf08507b4b86c229d78"
3
1require u-boot-socfpga.inc 4require u-boot-socfpga.inc
diff --git a/recipes-bsp/u-boot/u-boot-socfpga_2014.10.bb b/recipes-bsp/u-boot/u-boot-socfpga_2014.10.bb
new file mode 100755
index 0000000..cecd191
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-socfpga_2014.10.bb
@@ -0,0 +1,50 @@
1UBOOT_SUFFIX ?= "img"
2UBOOT_RAW_BINARY ?= "u-boot-dtb.bin"
3UBOOT_DTB ?= "u-boot.dtb"
4
5require ${COREBASE}/meta/recipes-bsp/u-boot/u-boot.inc
6
7FILESEXTRAPATHS_prepend := "${THISDIR}/u-boot:"
8
9LICENSE = "GPLv2+"
10LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
11
12PACKAGE_ARCH = "${MACHINE_ARCH}"
13
14PROVIDES += "u-boot"
15PKG_${PN} = "u-boot"
16PKG_${PN}-dev = "u-boot-dev"
17PKG_${PN}-dbg = "u-boot-dbg"
18
19S = "${WORKDIR}/git"
20
21# SPL (Second Program Loader) to be loaded over UART
22SPL_UART_BINARY ?= ""
23SPL_UART_IMAGE ?= "${SPL_UART_BINARY}-${MACHINE}-${PV}-${PR}"
24SPL_UART_SYMLINK ?= "${SPL_UART_BINARY}-${MACHINE}"
25
26do_deploy_append () {
27 install ${S}/${UBOOT_RAW_BINARY} ${DEPLOYDIR}/${UBOOT_RAW_BINARY}
28 install ${S}/${UBOOT_DTB} ${DEPLOYDIR}/${UBOOT_DTB}
29}
30
31# DEPEND on dtc-native for mainline u-boot because the mainline u-boot depends
32# on some of the latest syntax constructs for an appended in dtb used for
33# items like secure boot/image signing.
34DEPENDS += "dtc-native"
35
36DESCRIPTION = "Mainline u-boot bootloader"
37
38LIC_FILES_CHKSUM = "file://Licenses/README;md5=c7383a594871c03da76b3707929d2919"
39
40PV = "2014.10"
41
42UBOOT_BRANCH ?= "socfpga_v${PV}_arria10_bringup"
43UBOOT_REPO ?= "git://github.com/altera-opensource/u-boot-socfpga.git"
44UBOOT_PROT ?= "https"
45
46SRC_URI = "${UBOOT_REPO};protocol=${UBOOT_PROT};branch=${UBOOT_BRANCH}"
47
48#SoCEDS 15.1 release
49SRCREV = "21d6a65d68d84efba88ff21ceae9bc8f2aa06857"
50