summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-socfpga_v2016.05.bb
diff options
context:
space:
mode:
authorDalon Westergreen <dalon.westergreen@intel.com>2017-01-11 10:16:43 -0800
committerKhem Raj <raj.khem@gmail.com>2017-01-11 10:16:43 -0800
commit0c6e036fdfec58b69903a10e886a9dfae8fe4c9f (patch)
treed20289b0fe29ddea1e637248a68e2d0f7c20a89e /recipes-bsp/u-boot/u-boot-socfpga_v2016.05.bb
parentab2ee2812670be650d6a722de08dff9bf05131f8 (diff)
downloadmeta-altera-0c6e036fdfec58b69903a10e886a9dfae8fe4c9f.tar.gz
Update uboot and kernel recipes, and fix sdcard class (#44)
* u-boot-socfpga: update PV for all recipes and add common include for mainline uboot versions u-boot-socfpga versioning scheme varied, some prepended with a 'v' others not. u-boot mainline tags versions with vYYYY.MM so we should be consistent. Create a single include for all mainline uboot versions. Signed-off-by: Dalon Westergreen <dwesterg@gmail.com> * u-boot-socfpga: Add support for v2016.11 Signed-off-by: Dalon Westergreen <dwesterg@gmail.com> * Update sdcard image class and add to arria5 / cyclone 5 machine conf * Move arria5/cyclone5 to uboot-socfpga v2016.11 Signed-off-by: Dalon Westergreen <dwesterg@gmail.com> * Update sdcard script Seemed to be an issue with the rootfs partition being slightly smaller then the ROOTFS_SIZE in some cases. Signed-off-by: Dalon Westergreen <dalon.westergreen@intel.com> * uboot: Cleanup v2014.10 recipe v2014.10 is used for Arria10, at this time it does not support GCC6 which is the default for morty * Clean up arria5 and cyclone5 machine definitions Signed-off-by: Dalon Westergreen <dalon.westergreen@intel.com> * linux-socfpga: add 4.7 and 4.7 dev recipes Signed-off-by: Dalon Westergreen <dalon.westergreen@intel.com> * linux-socfpga: update srcrev for 4.6 kernel and remove 4.6 dev Signed-off-by: Dalon Westergreen <dalon.westergreen@intel.com> * linux-socfpga: delete 4.1 dev as 4.1 is no longer maintained * linux-socfpga: update 4.1.22 srcrev to latest release
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-socfpga_v2016.05.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-socfpga_v2016.05.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-socfpga_v2016.05.bb b/recipes-bsp/u-boot/u-boot-socfpga_v2016.05.bb
new file mode 100644
index 0000000..a4e1f44
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-socfpga_v2016.05.bb
@@ -0,0 +1,29 @@
1require u-boot-socfpga-common.inc
2require ${COREBASE}/meta/recipes-bsp/u-boot/u-boot.inc
3
4# This revision corresponds to the tag "v2016.05"
5# We use the revision in order to avoid having to fetch it from the
6# repo during parse
7SRCREV = "aeaec0e682f45b9e0c62c522fafea353931f73ed"
8
9DEPENDS += "dtc-native"
10
11do_install_append_10m50 () {
12 if [ "x${UBOOT_CONFIG}" != "x" ]
13 then
14 for config in ${UBOOT_MACHINE}; do
15 install -d ${D}/boot
16 install ${B}/${config}/${UBOOT_DTB_BINARY} ${D}/boot/${UBOOT_DTB_BINARY}
17 install ${B}/${config}/${UBOOT_NODTB_BINARY} ${D}/boot/${UBOOT_NODTB_BINARY}
18 done
19 else
20 install -d ${D}/boot
21 install ${B}/${config}/${UBOOT_DTB_BINARY} ${D}/boot/${UBOOT_DTB_BINARY}
22 install ${B}/${config}/${UBOOT_NODTB_BINARY} ${D}/boot/${UBOOT_NODTB_BINARY}
23 fi
24}
25
26do_deploy_append_10m50 () {
27 install ${D}/boot/${UBOOT_DTB_BINARY} ${DEPLOYDIR}/${UBOOT_DTB_BINARY}
28 install ${D}/boot/${UBOOT_NODTB_BINARY} ${DEPLOYDIR}/${UBOOT_NODTB_BINARY}
29}