summaryrefslogtreecommitdiffstats
path: root/conf
diff options
context:
space:
mode:
authorYves Vandervennet <yvanderv@opensource.altera.com>2014-09-04 13:43:44 -0500
committerKhem Raj <khem_raj@cable.comcast.com>2014-09-20 18:50:14 -0700
commit4e663cef8f0fb950a8751a4e3ae236cc85db244e (patch)
tree373d01078b5d3345fc50589fbdda70e05dbd02d9 /conf
downloadmeta-altera-4e663cef8f0fb950a8751a4e3ae236cc85db244e.tar.gz
Yocto layer for Altera's SoCFPGA
Signed-off-by: Yves Vandervennet <yvanderv@opensource.altera.com>
Diffstat (limited to 'conf')
-rw-r--r--conf/layer.conf14
-rw-r--r--conf/machine/include/socfpga.inc27
-rw-r--r--conf/machine/socfpga_arria5.conf8
-rw-r--r--conf/machine/socfpga_cyclone5.conf8
4 files changed, 57 insertions, 0 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
new file mode 100644
index 0000000..f611a31
--- /dev/null
+++ b/conf/layer.conf
@@ -0,0 +1,14 @@
1# We have a conf and classes directory, append to BBPATH
2BBPATH .= ":${LAYERDIR}"
3
4# We have a recipes directory, add to BBFILES
5BBFILES += "${LAYERDIR}/recipes*/*/*.bb ${LAYERDIR}/recipes*/*/*.bbappend"
6
7BBFILE_COLLECTIONS += "meta-altera"
8BBFILE_PATTERN_meta-altera := "^${LAYERDIR}/"
9# increase the number
10BBFILE_PRIORITY_meta-altera = "6"
11
12# yves
13BBDEBUG = "yes"
14
diff --git a/conf/machine/include/socfpga.inc b/conf/machine/include/socfpga.inc
new file mode 100644
index 0000000..60ba002
--- /dev/null
+++ b/conf/machine/include/socfpga.inc
@@ -0,0 +1,27 @@
1SOC_FAMILY = "socfpga"
2
3require conf/machine/include/tune-cortexa9.inc
4
5# this variable specifies the kernel to be built: linux-altera or linux-altera-ltsi
6# this affects the PREFERRED_PROVIDER of virtual/kernel
7# it can be overriden from the environment, using BB_ENV_EXTRAWHITE
8KERNEL_PROVIDER?="linux-altera-ltsi"
9PREFERRED_PROVIDER_virtual/kernel = "${KERNEL_PROVIDER}"
10
11PREFERRED_PROVIDER_virtual/bootloader = "u-boot-socfpga"
12
13# Increase this everytime you change something in the kernel
14MACHINE_KERNEL_PR = "r1"
15
16UBOOT_ENTRYPOINT = "0x80008000"
17UBOOT_LOADADDRESS = "0x80008000"
18
19SERIAL_CONSOLE = "115200 ttyS0"
20
21KERNEL_IMAGETYPE = "zImage"
22MACHINE_EXTRA_RRECOMMENDS = " kernel-modules"
23MACHINE_FEATURES = "kernel26"
24
25# file system images required
26IMAGE_FSTYPES ?= "cpio ext3 tar.gz"
27
diff --git a/conf/machine/socfpga_arria5.conf b/conf/machine/socfpga_arria5.conf
new file mode 100644
index 0000000..022c6a8
--- /dev/null
+++ b/conf/machine/socfpga_arria5.conf
@@ -0,0 +1,8 @@
1#@TYPE: Machine
2#@NAME: SOCFPGA
3#@DESCRIPTION: Machine configuration for the Cyclone V SoC"
4
5require conf/machine/include/socfpga.inc
6
7UBOOT_MACHINE = "socfpga_arria5"
8
diff --git a/conf/machine/socfpga_cyclone5.conf b/conf/machine/socfpga_cyclone5.conf
new file mode 100644
index 0000000..e4d3b5b
--- /dev/null
+++ b/conf/machine/socfpga_cyclone5.conf
@@ -0,0 +1,8 @@
1#@TYPE: Machine
2#@NAME: SOCFPGA
3#@DESCRIPTION: Machine configuration for the Cyclone V SoC"
4
5require conf/machine/include/socfpga.inc
6
7UBOOT_MACHINE = "socfpga_cyclone5"
8