summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDalon Westergreen <dalon.westergreen@intel.com>2017-01-13 12:53:43 -0800
committerKhem Raj <raj.khem@gmail.com>2017-01-13 12:53:43 -0800
commit9adaf656286bde3b64519411ac4709133aba60e4 (patch)
treedc865f1c790d2ac80f42b2faa978fd80952bf3a1
parente55b6c3747815357009c74e00bc6103d9c11dec4 (diff)
downloadmeta-altera-9adaf656286bde3b64519411ac4709133aba60e4.tar.gz
Add support to fix arria10 u-boot-socfpga v2014.10 build with gcc6 (#47)
* u-boot-socfpga: Remove unnecessary 10m50 additions in v2016.05 Signed-off-by: Dalon Westergreen <dalon.westergreen@intel.com> * Add fix to support gcc6 compilation of v2014.10 of uboot-socfpga Signed-off-by: Dalon Westergreen <dalon.westergreen@intel.com>
-rw-r--r--recipes-bsp/u-boot/files/v2014.10/fix-build-error-under-gcc6.patch91
-rw-r--r--recipes-bsp/u-boot/u-boot-socfpga_v2014.10.bb5
2 files changed, 95 insertions, 1 deletions
diff --git a/recipes-bsp/u-boot/files/v2014.10/fix-build-error-under-gcc6.patch b/recipes-bsp/u-boot/files/v2014.10/fix-build-error-under-gcc6.patch
new file mode 100644
index 0000000..18c5e74
--- /dev/null
+++ b/recipes-bsp/u-boot/files/v2014.10/fix-build-error-under-gcc6.patch
@@ -0,0 +1,91 @@
1From 07373b2e477ae61f9f6a0e2eff41be3276d92923 Mon Sep 17 00:00:00 2001
2From: yocto <yocto@yocto.org>
3Date: Thu, 2 Jun 2016 03:21:51 -0500
4Subject: [PATCH] fix build error under gcc6
5
6Fix the following error:
7| ../include/linux/compiler-gcc.h:114:30: fatal error: linux/compiler-gcc6.h: No such file or directory
8| #include gcc_header(__GNUC__)
9
10Signed-off-by: Zhenhua Luo <zhenhua.luo@nxp.com>
11
12Upstream-Status: Pending
13---
14 include/linux/compiler-gcc6.h | 65 +++++++++++++++++++++++++++++++++++++++++++
15 1 file changed, 65 insertions(+)
16 create mode 100644 include/linux/compiler-gcc6.h
17
18diff --git a/include/linux/compiler-gcc6.h b/include/linux/compiler-gcc6.h
19new file mode 100644
20index 0000000..c8c5659
21--- /dev/null
22+++ b/include/linux/compiler-gcc6.h
23@@ -0,0 +1,65 @@
24+#ifndef __LINUX_COMPILER_H
25+#error "Please don't include <linux/compiler-gcc5.h> directly, include <linux/compiler.h> instead."
26+#endif
27+
28+#define __used __attribute__((__used__))
29+#define __must_check __attribute__((warn_unused_result))
30+#define __compiler_offsetof(a, b) __builtin_offsetof(a, b)
31+
32+/* Mark functions as cold. gcc will assume any path leading to a call
33+ to them will be unlikely. This means a lot of manual unlikely()s
34+ are unnecessary now for any paths leading to the usual suspects
35+ like BUG(), printk(), panic() etc. [but let's keep them for now for
36+ older compilers]
37+
38+ Early snapshots of gcc 4.3 don't support this and we can't detect this
39+ in the preprocessor, but we can live with this because they're unreleased.
40+ Maketime probing would be overkill here.
41+
42+ gcc also has a __attribute__((__hot__)) to move hot functions into
43+ a special section, but I don't see any sense in this right now in
44+ the kernel context */
45+#define __cold __attribute__((__cold__))
46+
47+#define __UNIQUE_ID(prefix) __PASTE(__PASTE(__UNIQUE_ID_, prefix), __COUNTER__)
48+
49+#ifndef __CHECKER__
50+# define __compiletime_warning(message) __attribute__((warning(message)))
51+# define __compiletime_error(message) __attribute__((error(message)))
52+#endif /* __CHECKER__ */
53+
54+/*
55+ * Mark a position in code as unreachable. This can be used to
56+ * suppress control flow warnings after asm blocks that transfer
57+ * control elsewhere.
58+ *
59+ * Early snapshots of gcc 4.5 don't support this and we can't detect
60+ * this in the preprocessor, but we can live with this because they're
61+ * unreleased. Really, we need to have autoconf for the kernel.
62+ */
63+#define unreachable() __builtin_unreachable()
64+
65+/* Mark a function definition as prohibited from being cloned. */
66+#define __noclone __attribute__((__noclone__))
67+
68+/*
69+ * Tell the optimizer that something else uses this function or variable.
70+ */
71+#define __visible __attribute__((externally_visible))
72+
73+/*
74+ * GCC 'asm goto' miscompiles certain code sequences:
75+ *
76+ * http://gcc.gnu.org/bugzilla/show_bug.cgi?id=58670
77+ *
78+ * Work it around via a compiler barrier quirk suggested by Jakub Jelinek.
79+ *
80+ * (asm goto is automatically volatile - the naming reflects this.)
81+ */
82+#define asm_volatile_goto(x...) do { asm goto(x); asm (""); } while (0)
83+
84+#ifdef CONFIG_ARCH_USE_BUILTIN_BSWAP
85+#define __HAVE_BUILTIN_BSWAP32__
86+#define __HAVE_BUILTIN_BSWAP64__
87+#define __HAVE_BUILTIN_BSWAP16__
88+#endif /* CONFIG_ARCH_USE_BUILTIN_BSWAP */
89--
902.5.0
91
diff --git a/recipes-bsp/u-boot/u-boot-socfpga_v2014.10.bb b/recipes-bsp/u-boot/u-boot-socfpga_v2014.10.bb
index 5c82261..7804080 100644
--- a/recipes-bsp/u-boot/u-boot-socfpga_v2014.10.bb
+++ b/recipes-bsp/u-boot/u-boot-socfpga_v2014.10.bb
@@ -7,7 +7,10 @@ UBOOT_BRANCH ?= "socfpga_${PV}_arria10_bringup"
7UBOOT_REPO ?= "git://github.com/altera-opensource/u-boot-socfpga.git" 7UBOOT_REPO ?= "git://github.com/altera-opensource/u-boot-socfpga.git"
8UBOOT_PROT ?= "https" 8UBOOT_PROT ?= "https"
9 9
10SRC_URI = "${UBOOT_REPO};protocol=${UBOOT_PROT};branch=${UBOOT_BRANCH}" 10SRC_URI = "\
11 ${UBOOT_REPO};protocol=${UBOOT_PROT};branch=${UBOOT_BRANCH} \
12 file://v2014.10/fix-build-error-under-gcc6.patch \
13 "
11 14
12LICENSE = "GPLv2+" 15LICENSE = "GPLv2+"
13LIC_FILES_CHKSUM = "file://Licenses/README;md5=c7383a594871c03da76b3707929d2919" 16LIC_FILES_CHKSUM = "file://Licenses/README;md5=c7383a594871c03da76b3707929d2919"