summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-05-27 08:15:23 -0700
committerKhem Raj <raj.khem@gmail.com>2015-05-27 08:15:23 -0700
commit0b497d6c59f644eedeab0a6bbf9a258525ab40ef (patch)
treebeb09199ce5273e1060bad39198f6150babef347
parent5245a79b7e74be43b15f89b2952dec2971e51b6f (diff)
downloadmeta-altera-0b497d6c59f644eedeab0a6bbf9a258525ab40ef.tar.gz
linux-altera: Restrict the recipes only for altera machines
arria5 and cyclone5 for now are only ones supported in layer Remove executable mod on the recipe files Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--[-rwxr-xr-x]recipes-kernel/linux/linux-altera-ltsi-rt_3.10.bb1
-rw-r--r--[-rwxr-xr-x]recipes-kernel/linux/linux-altera-ltsi_3.10.bb1
-rw-r--r--[-rwxr-xr-x]recipes-kernel/linux/linux-altera.inc6
-rw-r--r--[-rwxr-xr-x]recipes-kernel/linux/linux-altera_3.15.bb2
4 files changed, 6 insertions, 4 deletions
diff --git a/recipes-kernel/linux/linux-altera-ltsi-rt_3.10.bb b/recipes-kernel/linux/linux-altera-ltsi-rt_3.10.bb
index 5d23758..48128a2 100755..100644
--- a/recipes-kernel/linux/linux-altera-ltsi-rt_3.10.bb
+++ b/recipes-kernel/linux/linux-altera-ltsi-rt_3.10.bb
@@ -3,4 +3,5 @@ DTB_SUBDIR="dts/"
3KERNEL_BRANCH ?= "socfpga-${PV}-ltsi-rt" 3KERNEL_BRANCH ?= "socfpga-${PV}-ltsi-rt"
4 4
5require recipes-kernel/linux/linux-altera.inc 5require recipes-kernel/linux/linux-altera.inc
6COMPATIBLE_MACHINE = "(arria5|cyclone5)"
6 7
diff --git a/recipes-kernel/linux/linux-altera-ltsi_3.10.bb b/recipes-kernel/linux/linux-altera-ltsi_3.10.bb
index 1ba1a60..3749338 100755..100644
--- a/recipes-kernel/linux/linux-altera-ltsi_3.10.bb
+++ b/recipes-kernel/linux/linux-altera-ltsi_3.10.bb
@@ -1,4 +1,5 @@
1DTB_SUBDIR="dts/" 1DTB_SUBDIR="dts/"
2 2
3require recipes-kernel/linux/linux-altera-ltsi.inc 3require recipes-kernel/linux/linux-altera-ltsi.inc
4COMPATIBLE_MACHINE = "(arria5|cyclone5)"
4 5
diff --git a/recipes-kernel/linux/linux-altera.inc b/recipes-kernel/linux/linux-altera.inc
index aa801e9..356ce3e 100755..100644
--- a/recipes-kernel/linux/linux-altera.inc
+++ b/recipes-kernel/linux/linux-altera.inc
@@ -26,9 +26,9 @@ do_configure() {
26 unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS MACHINE 26 unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS MACHINE
27 export CROSS_COMPILE="${TARGET_PREFIX}" 27 export CROSS_COMPILE="${TARGET_PREFIX}"
28 export ARCH=${ARCH} 28 export ARCH=${ARCH}
29 29
30 oe_runmake ${MACHINE_DEFCONFIG} CONFIG_BLK_DEV_INITRD=y 30 oe_runmake ${MACHINE_DEFCONFIG} CONFIG_BLK_DEV_INITRD=y
31 31
32 cp .config .config.ori 32 cp .config .config.ori
33 33
34 grep CONFIG_BLK_DEV_INITRD .config || echo "CONFIG_BLK_DEV_INITRD=y" >> .config 34 grep CONFIG_BLK_DEV_INITRD .config || echo "CONFIG_BLK_DEV_INITRD=y" >> .config
@@ -55,7 +55,7 @@ do_configure() {
55 sed -i "s|^CONFIG_INITRAMFS_ROOT_GID=.*$|# CONFIG_INITRAMFS_ROOT_GID is not set|g" .config 55 sed -i "s|^CONFIG_INITRAMFS_ROOT_GID=.*$|# CONFIG_INITRAMFS_ROOT_GID is not set|g" .config
56 sed -i "s|^CONFIG_INITRAMFS_COMPRESSION_NONE=.*$|# CONFIG_INITRAMFS_COMPRESSION_NONE is not set|g" .config 56 sed -i "s|^CONFIG_INITRAMFS_COMPRESSION_NONE=.*$|# CONFIG_INITRAMFS_COMPRESSION_NONE is not set|g" .config
57 oe_runmake oldconfig 57 oe_runmake oldconfig
58 fi 58 fi
59} 59}
60 60
61kernel_do_compile() { 61kernel_do_compile() {
diff --git a/recipes-kernel/linux/linux-altera_3.15.bb b/recipes-kernel/linux/linux-altera_3.15.bb
index 535b526..0062378 100755..100644
--- a/recipes-kernel/linux/linux-altera_3.15.bb
+++ b/recipes-kernel/linux/linux-altera_3.15.bb
@@ -3,4 +3,4 @@ DTB_SUBDIR="dts/"
3KERNEL_DEVICETREE = "socfpga_cyclone5_socdk socfpga_arria5_socdk socfpga_vt" 3KERNEL_DEVICETREE = "socfpga_cyclone5_socdk socfpga_arria5_socdk socfpga_vt"
4 4
5require recipes-kernel/linux/linux-altera-latest.inc 5require recipes-kernel/linux/linux-altera-latest.inc
6 6COMPATIBLE_MACHINE = "(arria5|cyclone5)"