summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-04-17 15:05:15 -0700
committerKhem Raj <raj.khem@gmail.com>2016-04-17 15:05:15 -0700
commitb990abff205f081241947f263c674b9529c50851 (patch)
treee1859db724ddde5b7515a860074987cd9cd3d4b7
parent201a8a118abfecdbcc9deae4595b3b4e469f0b39 (diff)
parent049b223896ce569304e565f608c6a03bf2342aa6 (diff)
downloadmeta-altera-b990abff205f081241947f263c674b9529c50851.tar.gz
Merge pull request #23 from dwesterg/master
Add support for mainline uboot for cyclone5 / arria5 devices
-rw-r--r--conf/machine/arria5.conf5
-rw-r--r--conf/machine/cyclone5.conf5
-rwxr-xr-xrecipes-bsp/u-boot/u-boot-socfpga_2013.01.01.bb4
-rw-r--r--recipes-bsp/u-boot/u-boot-socfpga_2016.03.bb28
4 files changed, 34 insertions, 8 deletions
diff --git a/conf/machine/arria5.conf b/conf/machine/arria5.conf
index 8589f94..193403c 100644
--- a/conf/machine/arria5.conf
+++ b/conf/machine/arria5.conf
@@ -4,8 +4,9 @@
4 4
5require conf/machine/include/socfpga.inc 5require conf/machine/include/socfpga.inc
6 6
7PREFERRED_VERSION_u-boot-socfpga ?= "2013.01.01" 7PREFERRED_VERSION_u-boot-socfpga ?= "2016.03"
8UBOOT_MACHINE = "socfpga_arria5" 8
9UBOOT_CONFIG ?= "arria5-socdk"
9 10
10KMACHINE = "arria5" 11KMACHINE = "arria5"
11 12
diff --git a/conf/machine/cyclone5.conf b/conf/machine/cyclone5.conf
index fd74005..7d0aab0 100644
--- a/conf/machine/cyclone5.conf
+++ b/conf/machine/cyclone5.conf
@@ -4,8 +4,9 @@
4 4
5require conf/machine/include/socfpga.inc 5require conf/machine/include/socfpga.inc
6 6
7PREFERRED_VERSION_u-boot-socfpga ?= "2013.01.01" 7PREFERRED_VERSION_u-boot-socfpga ?= "2016.03"
8UBOOT_MACHINE = "socfpga_cyclone5" 8
9UBOOT_CONFIG ?= "cyclone5-socdk"
9 10
10KMACHINE = "cyclone5" 11KMACHINE = "cyclone5"
11 12
diff --git a/recipes-bsp/u-boot/u-boot-socfpga_2013.01.01.bb b/recipes-bsp/u-boot/u-boot-socfpga_2013.01.01.bb
deleted file mode 100755
index 124b87c..0000000
--- a/recipes-bsp/u-boot/u-boot-socfpga_2013.01.01.bb
+++ /dev/null
@@ -1,4 +0,0 @@
1# SoCEDS 15.1 u-Boot release
2UBOOT_TAG = "d141e218f3195e305c1521a0d67c81b7cb504b71"
3
4require u-boot-socfpga.inc
diff --git a/recipes-bsp/u-boot/u-boot-socfpga_2016.03.bb b/recipes-bsp/u-boot/u-boot-socfpga_2016.03.bb
new file mode 100644
index 0000000..1d0376e
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-socfpga_2016.03.bb
@@ -0,0 +1,28 @@
1require ${COREBASE}/meta/recipes-bsp/u-boot/u-boot.inc
2
3# This revision is the v2016.03 release
4SRCREV = "df61a74e6845ec9bdcdd48d2aff5e9c2c6debeaa"
5
6LICENSE = "GPLv2+"
7LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
8
9PV = "v2016.03"
10PV_append = "+git${SRCPV}"
11
12DEPENDS += "dtc-native"
13
14UBOOT_CONFIG ??= "cyclone5-socdk arria5-socdk de0-nano-soc sockit socrates"
15UBOOT_CONFIG[cyclone5-socdk] = "socfpga_cyclone5_defconfig"
16UBOOT_CONFIG[arria5-socdk] = "socfpga_arria5_defconfig"
17UBOOT_CONFIG[de0-nano-soc] = "socfpga_de0_nano_soc_defconfig"
18UBOOT_CONFIG[mcvevk] = "socfpga_mcvevk_defconfig"
19UBOOT_CONFIG[sockit] = "socfpga_sockit_defconfig"
20UBOOT_CONFIG[socrates] = "socfpga_socrates_defconfig"
21UBOOT_CONFIG[sr1500] = "socfpga_sr1500_defconfig"
22
23UBOOT_SUFFIX = "img"
24
25SPL_BINARY_cyclone5 = "u-boot-with-spl.sfp"
26SPL_BINARY_arria5 = "u-boot-with-spl.sfp"
27
28