summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDalon Westergreen <dwesterg@gmail.com>2015-11-12 00:19:11 -0800
committerDalon Westergreen <dwesterg@gmail.com>2015-11-12 00:19:11 -0800
commitae10c5b4c27fa21f70623e63ecd65c2927b80c0d (patch)
tree999eb328a52f4747d088c54f47ade8afe76c61bd
parent378e9ac39b306d0ee12d4ac86708d64c8ce8ddea (diff)
downloadmeta-altera-ae10c5b4c27fa21f70623e63ecd65c2927b80c0d.tar.gz
Add Arria10 initial
-rw-r--r--conf/machine/arria10.conf13
-rwxr-xr-xrecipes-bsp/u-boot/u-boot-socfpga_2014.10.bb49
2 files changed, 62 insertions, 0 deletions
diff --git a/conf/machine/arria10.conf b/conf/machine/arria10.conf
new file mode 100644
index 0000000..676752d
--- /dev/null
+++ b/conf/machine/arria10.conf
@@ -0,0 +1,13 @@
1#@TYPE: Machine
2#@NAME: arria5
3#@DESCRIPTION: Machine configuration for the Arria 10 SoC"
4
5require conf/machine/include/socfpga.inc
6
7PREFERRED_VERSION_u-boot-socfpga = "2014.10"
8UBOOT_MACHINE = "socfpga_arria10_defconfig"
9
10KMACHINE = "arria10"
11
12KERNEL_DEVICETREE_arria10 ?= "socfpga_arria10_socdk_sdmmc.dtb socfpga_arria10_socdk_qspi.dtb socfpga_arria10_swvp.dtb"
13
diff --git a/recipes-bsp/u-boot/u-boot-socfpga_2014.10.bb b/recipes-bsp/u-boot/u-boot-socfpga_2014.10.bb
new file mode 100755
index 0000000..ff9f248
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-socfpga_2014.10.bb
@@ -0,0 +1,49 @@
1UBOOT_SUFFIX ?= "img"
2UBOOT_RAW_BINARY ?= "u-boot-dtb.bin"
3UBOOT_DTB ?= "u-boot.dtb"
4
5require ${COREBASE}/meta/recipes-bsp/u-boot/u-boot.inc
6
7FILESEXTRAPATHS_prepend := "${THISDIR}/u-boot:"
8
9LICENSE = "GPLv2+"
10LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
11
12PACKAGE_ARCH = "${MACHINE_ARCH}"
13
14PROVIDES += "u-boot"
15PKG_${PN} = "u-boot"
16PKG_${PN}-dev = "u-boot-dev"
17PKG_${PN}-dbg = "u-boot-dbg"
18
19S = "${WORKDIR}/git"
20
21# SPL (Second Program Loader) to be loaded over UART
22SPL_UART_BINARY ?= ""
23SPL_UART_IMAGE ?= "${SPL_UART_BINARY}-${MACHINE}-${PV}-${PR}"
24SPL_UART_SYMLINK ?= "${SPL_UART_BINARY}-${MACHINE}"
25
26do_deploy_append () {
27 install ${S}/${UBOOT_RAW_BINARY} ${DEPLOYDIR}/${UBOOT_RAW_BINARY}
28 install ${S}/${UBOOT_DTB} ${DEPLOYDIR}/${UBOOT_DTB}
29}
30
31# DEPEND on dtc-native for mainline u-boot because the mainline u-boot depends
32# on some of the latest syntax constructs for an appended in dtb used for
33# items like secure boot/image signing.
34DEPENDS += "dtc-native"
35
36DESCRIPTION = "Mainline u-boot bootloader"
37
38LIC_FILES_CHKSUM = "file://Licenses/README;md5=c7383a594871c03da76b3707929d2919"
39
40PV = "v2014.10"
41
42UBOOT_BRANCH ?= "socfpga_${PV}_arria10_bringup"
43UBOOT_REPO ?= "git://github.com/altera-opensource/u-boot-socfpga.git"
44UBOOT_PROT ?= "https"
45
46SRC_URI = "${UBOOT_REPO};protocol=${UBOOT_PROT};branch=${UBOOT_BRANCH}"
47
48SRCREV = "${AUTOREV}"
49