summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDalon Westergreen <dwesterg@gmail.com>2015-11-12 00:18:37 -0800
committerDalon Westergreen <dwesterg@gmail.com>2015-11-12 00:18:37 -0800
commit378e9ac39b306d0ee12d4ac86708d64c8ce8ddea (patch)
treece3c4b4a98784b0f9a88489cdc241f3044f9e9c6
parent64e2e93406ebf2a30dc198ab0fb27e8f0643a204 (diff)
downloadmeta-altera-378e9ac39b306d0ee12d4ac86708d64c8ce8ddea.tar.gz
Clean up KERNEL_DEVICETREE in machine conf and kernel recipes
-rw-r--r--conf/machine/arria5.conf2
-rw-r--r--conf/machine/cyclone5.conf2
-rw-r--r--recipes-kernel/linux/linux-altera-ltsi-rt_3.10.bb2
-rw-r--r--recipes-kernel/linux/linux-altera-ltsi_3.10.bb2
-rw-r--r--recipes-kernel/linux/linux-altera_4.0.bb2
-rw-r--r--recipes-kernel/linux/linux-altera_4.1.bb2
-rw-r--r--recipes-kernel/linux/linux-altera_4.2.bb2
7 files changed, 4 insertions, 10 deletions
diff --git a/conf/machine/arria5.conf b/conf/machine/arria5.conf
index e94d3df..3105113 100644
--- a/conf/machine/arria5.conf
+++ b/conf/machine/arria5.conf
@@ -9,3 +9,5 @@ UBOOT_MACHINE = "socfpga_arria5"
9 9
10KMACHINE = "arria5" 10KMACHINE = "arria5"
11 11
12KERNEL_DEVICETREE_linux-altera ?= "socfpga_arria5_socdk.dtb"
13KERNEL_DEVICETREE_linux-altera-ltsi ?= "socfpga_arria5.dtb"
diff --git a/conf/machine/cyclone5.conf b/conf/machine/cyclone5.conf
index b993095..e6b9366 100644
--- a/conf/machine/cyclone5.conf
+++ b/conf/machine/cyclone5.conf
@@ -9,3 +9,5 @@ UBOOT_MACHINE = "socfpga_cyclone5"
9 9
10KMACHINE = "cyclone5" 10KMACHINE = "cyclone5"
11 11
12KERNEL_DEVICETREE_linux-altera ?= "socfpga_cyclone5_socdk.dtb socfpga_cyclone5_sockit.dtb socfpga_cyclone5_socrates.dtb"
13KERNEL_DEVICETREE_linux-altera-ltsi ?= "socfpga_cyclone5.dtb"
diff --git a/recipes-kernel/linux/linux-altera-ltsi-rt_3.10.bb b/recipes-kernel/linux/linux-altera-ltsi-rt_3.10.bb
index 5d8db2c..6626393 100644
--- a/recipes-kernel/linux/linux-altera-ltsi-rt_3.10.bb
+++ b/recipes-kernel/linux/linux-altera-ltsi-rt_3.10.bb
@@ -2,5 +2,3 @@ include linux-altera.inc
2LINUX_VERSION = "3.10" 2LINUX_VERSION = "3.10"
3LINUX_VERSION_SUFFIX = "-ltsi-rt" 3LINUX_VERSION_SUFFIX = "-ltsi-rt"
4 4
5KERNEL_DEVICETREE_cyclone5 ?= "socfpga_cyclone5.dtb"
6KERNEL_DEVICETREE_arria5 ?= "socfpga_arria5.dtb"
diff --git a/recipes-kernel/linux/linux-altera-ltsi_3.10.bb b/recipes-kernel/linux/linux-altera-ltsi_3.10.bb
index fa3954d..523cd55 100644
--- a/recipes-kernel/linux/linux-altera-ltsi_3.10.bb
+++ b/recipes-kernel/linux/linux-altera-ltsi_3.10.bb
@@ -2,5 +2,3 @@ include linux-altera.inc
2LINUX_VERSION = "3.10" 2LINUX_VERSION = "3.10"
3LINUX_VERSION_SUFFIX = "-ltsi" 3LINUX_VERSION_SUFFIX = "-ltsi"
4 4
5KERNEL_DEVICETREE_cyclone5 ?= "socfpga_cyclone5.dtb"
6KERNEL_DEVICETREE_arria5 ?= "socfpga_arria5.dtb"
diff --git a/recipes-kernel/linux/linux-altera_4.0.bb b/recipes-kernel/linux/linux-altera_4.0.bb
index 925fc2f..e40a16c 100644
--- a/recipes-kernel/linux/linux-altera_4.0.bb
+++ b/recipes-kernel/linux/linux-altera_4.0.bb
@@ -1,5 +1,3 @@
1include linux-altera.inc 1include linux-altera.inc
2LINUX_VERSION = "4.0" 2LINUX_VERSION = "4.0"
3 3
4KERNEL_DEVICETREE_cyclone5 ?= "socfpga_cyclone5_socdk.dtb socfpga_cyclone5_sockit.dtb socfpga_cyclone5_socrates.dtb"
5KERNEL_DEVICETREE_arria5 ?= "socfpga_arria5_socdk.dtb"
diff --git a/recipes-kernel/linux/linux-altera_4.1.bb b/recipes-kernel/linux/linux-altera_4.1.bb
index 79485ec..60212b4 100644
--- a/recipes-kernel/linux/linux-altera_4.1.bb
+++ b/recipes-kernel/linux/linux-altera_4.1.bb
@@ -1,5 +1,3 @@
1include linux-altera.inc 1include linux-altera.inc
2LINUX_VERSION = "4.1" 2LINUX_VERSION = "4.1"
3 3
4KERNEL_DEVICETREE_cyclone5 ?= "socfpga_cyclone5_socdk.dtb socfpga_cyclone5_sockit.dtb socfpga_cyclone5_socrates.dtb"
5KERNEL_DEVICETREE_arria5 ?= "socfpga_arria5_socdk.dtb"
diff --git a/recipes-kernel/linux/linux-altera_4.2.bb b/recipes-kernel/linux/linux-altera_4.2.bb
index f1432b2..556427b 100644
--- a/recipes-kernel/linux/linux-altera_4.2.bb
+++ b/recipes-kernel/linux/linux-altera_4.2.bb
@@ -1,5 +1,3 @@
1include linux-altera.inc 1include linux-altera.inc
2LINUX_VERSION = "4.2" 2LINUX_VERSION = "4.2"
3 3
4KERNEL_DEVICETREE_cyclone5 ?= "socfpga_cyclone5_socdk.dtb socfpga_cyclone5_sockit.dtb socfpga_cyclone5_socrates.dtb"
5KERNEL_DEVICETREE_arria5 ?= "socfpga_arria5_socdk.dtb"