summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Galbusera <gizero@gmail.com>2016-05-03 16:34:23 +0200
committerAndrea Galbusera <gizero@gmail.com>2016-05-13 11:54:23 +0200
commit03d5c5bcce980c5ebdcfa370e6ce1c93b9d33100 (patch)
tree992372fcac6df25a61f2d46c2a5a44f1ab982a43
parenta46550fc70acdbba33cfbb1b7cc39f54808c5cfd (diff)
downloadmeta-altera-03d5c5bcce980c5ebdcfa370e6ce1c93b9d33100.tar.gz
linux-yocto_4.4: drop bbappend from jethro branch
* this version of linux-yocto is not available in poky jethro branch, leading to bitbake complaining for missing recipe fixes: ERROR: No recipes available for: meta-altera/recipes-kernel/linux/linux-yocto_4.4.bbappend
-rw-r--r--recipes-kernel/linux/linux-yocto_4.4.bbappend18
1 files changed, 0 insertions, 18 deletions
diff --git a/recipes-kernel/linux/linux-yocto_4.4.bbappend b/recipes-kernel/linux/linux-yocto_4.4.bbappend
deleted file mode 100644
index fe9a35f..0000000
--- a/recipes-kernel/linux/linux-yocto_4.4.bbappend
+++ /dev/null
@@ -1,18 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/config:"
2
3COMPATIBLE_MACHINE_10m50 = "10m50"
4COMPATIBLE_MACHINE_generic-nios2 = "generic-nios2"
5SRC_URI_append_nios2 = " file://defconfig "
6
7# Force machine Tunings in kernel config
8do_configure_prepend_nios2() {
9 sed -i -e /CONFIG_NIOS2_HW_MUL_SUPPORT/d ${WORKDIR}/defconfig
10 sed -i -e /CONFIG_NIOS2_HW_MULX_SUPPORT/d ${WORKDIR}/defconfig
11 sed -i -e /CONFIG_NIOS2_HW_DIV_SUPPORT/d ${WORKDIR}/defconfig
12 sed -i -e /CONFIG_NIOS2_FPU_SUPPORT/d ${WORKDIR}/defconfig
13 echo "${@base_contains('TUNE_FEATURES', 'hw-mul', 'CONFIG_NIOS2_HW_MUL_SUPPORT=y', '#CONFIG_NIOS2_HW_MUL_SUPPORT is not set', d)}" >> ${WORKDIR}/defconfig
14 echo "${@base_contains('TUNE_FEATURES', 'hw-mulx', 'CONFIG_NIOS2_HW_MULX_SUPPORT=y', '#CONFIG_NIOS2_HW_MULX_SUPPORT is not set', d)}" >> ${WORKDIR}/defconfig
15 echo "${@base_contains('TUNE_FEATURES', 'hw-div', 'CONFIG_NIOS2_HW_DIV_SUPPORT=y', '#CONFIG_NIOS2_HW_DIV_SUPPORT is not set', d)}" >> ${WORKDIR}/defconfig
16 echo "${@base_contains('TUNE_FEATURES', 'fpu-custom', 'CONFIG_NIOS2_FPU_SUPPORT=y', '#CONFIG_NIOS2_FPU_SUPPORT is not set', d)}" >> ${WORKDIR}/defconfig
17 echo "${@base_contains('TUNE_FEATURES', 'fpu-customdiv', 'CONFIG_NIOS2_FPU_SUPPORT=y', '#CONFIG_NIOS2_FPU_SUPPORT is not set', d)}" >> ${WORKDIR}/defconfig
18}