summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/jailhouse-linux_4.14.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/jailhouse-linux_4.14.6.bb')
-rw-r--r--recipes-kernel/linux/jailhouse-linux_4.14.6.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes-kernel/linux/jailhouse-linux_4.14.6.bb b/recipes-kernel/linux/jailhouse-linux_4.14.6.bb
new file mode 100644
index 0000000..3cd4e97
--- /dev/null
+++ b/recipes-kernel/linux/jailhouse-linux_4.14.6.bb
@@ -0,0 +1,32 @@
1SECTION = "kernel"
2DESCRIPTION = "Mainline Linux kernel"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
5COMPATIBLE_MACHINE = "(sun4i|sun5i|sun7i)"
6
7inherit kernel
8
9require recipes-kernel/linux/linux-dtb.inc
10require recipes-kernel/linux/linux.inc
11
12# Pull in the devicetree files into the rootfs
13RDEPENDS_kernel-base += "kernel-devicetree"
14
15KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT}"
16
17S = "${WORKDIR}/linux-${PV}"
18
19SRC_URI[md5sum] = "938baaf8fd3d232e9fbc2f402adf0d3f"
20SRC_URI[sha256sum] = "0907678ba9ea146ddbdecd0a0b6363f56b896b5c61c9a15e809effb3ea346ccc"
21
22
23SRC_URI = "https://www.kernel.org/pub/linux/kernel/v4.x/linux-${PV}.tar.xz \
24 file://defconfig \
25 "
26
27SRC_URI_append_jailhouse-bpi = " \
28 file://jailhouse-required-symbol-export.patch \
29 file://jailhouse-required-symbol-export_2.patch \
30 file://jailhouse-required-symbol-export_3.patch \
31 "
32