summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOla Redell <ola.redell@codiax.se>2019-05-27 12:57:30 +0200
committerOla Redell <ola.redell@codiax.se>2019-05-27 12:59:13 +0200
commitf2f6d83741066584e5d5e5c131c4ce80102a84c1 (patch)
tree5cbae09729267c9e9e49f97dfdcfa91a1a9ee178
parent26424f0094e547faf73e432b852368224d0a7bbd (diff)
downloadmeta-jailhouse-f2f6d83741066584e5d5e5c131c4ce80102a84c1.tar.gz
Pulling in changes from meta-fsl-... layer and raising layer priority to 9
Needed to take priority over meta-fsl-... jailhouse recipe
-rw-r--r--conf/layer.conf2
-rw-r--r--recipes-jailhouse/jailhouse/jailhouse.inc37
-rw-r--r--recipes-kernel/linux/jailhouse-linux_4.14.6.bb2
3 files changed, 30 insertions, 11 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index 5826443..133f215 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -7,6 +7,6 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
7 7
8BBFILE_COLLECTIONS += "jailhouse" 8BBFILE_COLLECTIONS += "jailhouse"
9BBFILE_PATTERN_jailhouse = "^${LAYERDIR}/" 9BBFILE_PATTERN_jailhouse = "^${LAYERDIR}/"
10BBFILE_PRIORITY_jailhouse = "6" 10BBFILE_PRIORITY_jailhouse = "9"
11 11
12LAYERSERIES_COMPAT_jailhouse = "sumo" \ No newline at end of file 12LAYERSERIES_COMPAT_jailhouse = "sumo" \ No newline at end of file
diff --git a/recipes-jailhouse/jailhouse/jailhouse.inc b/recipes-jailhouse/jailhouse/jailhouse.inc
index e304c4c..c6d959a 100644
--- a/recipes-jailhouse/jailhouse/jailhouse.inc
+++ b/recipes-jailhouse/jailhouse/jailhouse.inc
@@ -25,6 +25,8 @@ JH_CONFIG ?= "${S}/ci/jailhouse-config-x86.h"
25JH_CONFIG_x86 ?= "${S}/ci/jailhouse-config-x86.h" 25JH_CONFIG_x86 ?= "${S}/ci/jailhouse-config-x86.h"
26JH_CONFIG_x86-64 ?= "${S}/ci/jailhouse-config-x86.h" 26JH_CONFIG_x86-64 ?= "${S}/ci/jailhouse-config-x86.h"
27JH_CONFIG_arm ?= "${S}/ci/jailhouse-config-banana-pi.h" 27JH_CONFIG_arm ?= "${S}/ci/jailhouse-config-banana-pi.h"
28JH_CONFIG_imx8mqevk = "${S}/ci/jailhouse-config-imx8mq-evk.h"
29JH_CONFIG_imx8mmevk = "${S}/ci/jailhouse-config-imx8mm-evk.h"
28 30
29do_configure() { 31do_configure() {
30 if [ -d ${STAGING_DIR_HOST}/${CELLCONF_DIR} ]; 32 if [ -d ${STAGING_DIR_HOST}/${CELLCONF_DIR} ];
@@ -40,17 +42,15 @@ do_configure() {
40 42
41USER_SPACE_CFLAGS = '${CFLAGS} -DLIBEXECDIR=\\\"${libexecdir}\\\" \ 43USER_SPACE_CFLAGS = '${CFLAGS} -DLIBEXECDIR=\\\"${libexecdir}\\\" \
42 -DJAILHOUSE_VERSION=\\\"$JAILHOUSE_VERSION\\\" \ 44 -DJAILHOUSE_VERSION=\\\"$JAILHOUSE_VERSION\\\" \
43 -Wall -Wextra -Wmissing-declarations -Wmissing-prototypes \ 45 -Wall -Wextra -Wmissing-declarations -Wmissing-prototypes -Werror \
44 -Werror -D__LINUX_COMPILER_TYPES_H \
45 -I../driver' 46 -I../driver'
46 47
47TOOLS_SRC_DIR = "${S}/tools" 48TOOLS_SRC_DIR = "${S}/tools"
48TOOLS_OBJ_DIR = "${S}/tools" 49TOOLS_OBJ_DIR = "${S}/tools"
49 50
50export LDFLAGS = ""
51
52do_compile() { 51do_compile() {
53 oe_runmake V=0 \ 52 unset LDFLAGS
53 oe_runmake V=0 CC="${CC}" \
54 CROSS_COMPILE=${TARGET_PREFIX} \ 54 CROSS_COMPILE=${TARGET_PREFIX} \
55 KDIR=${STAGING_KERNEL_BUILDDIR} 55 KDIR=${STAGING_KERNEL_BUILDDIR}
56 56
@@ -67,27 +67,46 @@ do_compile() {
67 ${TOOLS_OBJ_DIR}/jailhouse.8 ${TOOLS_OBJ_DIR}/jailhouse-cell.8 \ 67 ${TOOLS_OBJ_DIR}/jailhouse.8 ${TOOLS_OBJ_DIR}/jailhouse-cell.8 \
68 ${TOOLS_OBJ_DIR}/jailhouse-enable.8 \ 68 ${TOOLS_OBJ_DIR}/jailhouse-enable.8 \
69 ${TOOLS_OBJ_DIR}/jailhouse 69 ${TOOLS_OBJ_DIR}/jailhouse
70
71 #oe_runmake V=1 CFLAGS="${USER_SPACE_CFLAGS}" src=${TOOLS_SRC_DIR} obj=${TOOLS_OBJ_DIR} ${TOOLS_OBJ_DIR}/jailhouse-config-collect ${TOOLS_OBJ_DIR}/jailhouse
70} 72}
71 73
72do_install() { 74do_install() {
73 oe_runmake \ 75 oe_runmake V=1 \
76 LDFLAGS="" \
77 CC="${CC}" \
74 CROSS_COMPILE=${TARGET_PREFIX} \ 78 CROSS_COMPILE=${TARGET_PREFIX} \
75 KDIR=${STAGING_KERNEL_BUILDDIR} \ 79 KDIR=${STAGING_KERNEL_BUILDDIR} \
76 DESTDIR=${D} install 80 DESTDIR=${D} install
77 81
78 distutils_do_install 82 #distutils_do_install
79 83 distutils_do_compile
84
80 install -d ${D}${CELL_DIR} 85 install -d ${D}${CELL_DIR}
81 install ${B}/configs/${JH_ARCH}/*.cell ${D}${CELL_DIR}/ 86 install ${B}/configs/${ARCH}/*.cell ${D}${CELL_DIR}/
82 87
83 install -d ${D}${INMATES_DIR} 88 install -d ${D}${INMATES_DIR}
89 install -d ${D}${INMATES_DIR}/tools/${ARCH}
84 install ${B}/inmates/demos/${ARCH}/*.bin ${D}${INMATES_DIR} 90 install ${B}/inmates/demos/${ARCH}/*.bin ${D}${INMATES_DIR}
91
92 install -d ${D}${JH_DATADIR}/tools
93 install ${B}/tools/jailhouse-cell-linux ${D}${JH_DATADIR}/tools
94 install ${B}/tools/jailhouse-cell-stats ${D}${JH_DATADIR}/tools
95 install ${B}/tools/jailhouse-config-collect ${D}${JH_DATADIR}/tools
96 install ${B}/tools/jailhouse-config-create ${D}${JH_DATADIR}/tools
97 install ${B}/tools/jailhouse-gcov-extract ${D}${JH_DATADIR}/tools
98 install ${B}/tools/jailhouse-hardware-check ${D}${JH_DATADIR}/tools
99 install ${B}/inmates/tools/${JH_ARCH}/linux-loader.bin ${D}${INMATES_DIR}/tools/${JH_ARCH}
100
101 install -d ${D}${PYTHON_SITEPACKAGES_DIR}/pyjailhouse
102 install -m 0644 ${B}/build${base_libdir}/pyjailhouse/*.py ${D}${PYTHON_SITEPACKAGES_DIR}/pyjailhouse
85} 103}
86 104
87PACKAGE_BEFORE_PN = "kernel-module-jailhouse" 105PACKAGE_BEFORE_PN = "kernel-module-jailhouse"
88FILES_${PN} += "${base_libdir}/firmware ${libexecdir} ${sbindir} ${JH_DATADIR}" 106FILES_${PN} += "${base_libdir}/firmware ${libexecdir} ${sbindir} ${JH_DATADIR}"
89 107
90KERNEL_MODULE_AUTOLOAD += "jailhouse" 108KERNEL_MODULE_AUTOLOAD += "jailhouse"
109INSANE_SKIP_${PN} = "ldflags"
91 110
92python __anonymous () { 111python __anonymous () {
93 # Setup DEPENDS and RDEPENDS to included cells" 112 # Setup DEPENDS and RDEPENDS to included cells"
diff --git a/recipes-kernel/linux/jailhouse-linux_4.14.6.bb b/recipes-kernel/linux/jailhouse-linux_4.14.6.bb
index 3cd4e97..d072f5b 100644
--- a/recipes-kernel/linux/jailhouse-linux_4.14.6.bb
+++ b/recipes-kernel/linux/jailhouse-linux_4.14.6.bb
@@ -10,7 +10,7 @@ require recipes-kernel/linux/linux-dtb.inc
10require recipes-kernel/linux/linux.inc 10require recipes-kernel/linux/linux.inc
11 11
12# Pull in the devicetree files into the rootfs 12# Pull in the devicetree files into the rootfs
13RDEPENDS_kernel-base += "kernel-devicetree" 13RDEPENDS_${KERNEL_PACKAGE_NAME}-base += "kernel-devicetree"
14 14
15KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT}" 15KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT}"
16 16